aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xerces-c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/xerces-c/Makefile')
-rw-r--r--textproc/xerces-c/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/textproc/xerces-c/Makefile b/textproc/xerces-c/Makefile
new file mode 100644
index 000000000000..3321ab7b967f
--- /dev/null
+++ b/textproc/xerces-c/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: xerces-c
+# Date created: 29 December 2001
+# Whom: kiesel
+#
+# $FreeBSD$
+#
+
+PORTNAME= xerces_c
+PORTVERSION= 1.6.0
+CATEGORIES= textproc
+MASTER_SITES= http://xml.apache.org/dist/xerces-c/stable/ \
+ http://document-root.de/xerces-c-mirror/
+DISTNAME= xerces-c-src1_6_0
+
+MAINTAINER= kiesel@schlund.de
+
+INSTALLS_SHLIB=yes
+LDCONFIG_DIRS= ${PREFIX}/lib
+
+CONFIGURE_WRKSRC= ${WRKSRC}/src
+BUILD_WRKSRC= ${WRKSRC}/src
+INSTALL_WRKSRC= ${WRKSRC}/src
+
+# Set this to where the source lives
+MAKE_ENV+= XERCESCROOT=${WRKSRC}
+
+# If configure fails, try this:
+#CONFIGURE_SCRIPT= runConfigure -pfreebsd
+
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+
+pre-configure:
+ ${CHMOD} 700 ${CONFIGURE_WRKSRC}/runConfigure
+ ${CHMOD} 700 ${CONFIGURE_WRKSRC}/configure
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/lib/libxerces-c1_6_0.so
+
+.include <bsd.port.mk>