aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xerces-c3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/xerces-c3/Makefile')
-rw-r--r--textproc/xerces-c3/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/textproc/xerces-c3/Makefile b/textproc/xerces-c3/Makefile
index a69200fa745b..bc8f8402951e 100644
--- a/textproc/xerces-c3/Makefile
+++ b/textproc/xerces-c3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xerces-c
PORTVERSION= 3.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= APACHE/xerces/c/3/sources
PKGNAMESUFFIX= 3
@@ -14,15 +14,15 @@ COMMENT= Validating XML parser from the Apache XML Project
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS_DEFINE= DOCS
-OPTIONS_SUB= yes
-
-CMAKE_ARGS= -Dnetwork=ON \
- -Dthreads=ON \
- -Dtranscoder=iconv
+CONFIGURE_ARGS= --enable-netaccessor-socket \
+ --enable-transcoder-iconv \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+MAKE_ENV= XERCESCROOT=${WRKSRC}
TEST_TARGET= check
USE_LDCONFIG= yes
-USES= cmake cpe iconv pathfix
+USES= cpe gmake iconv libtool pathfix
PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
@@ -30,11 +30,8 @@ CPE_PRODUCT= xerces-c++
CPE_VENDOR= apache
post-patch:
- @${REINPLACE_CMD} -e '/list(APPEND netaccessors curl)/d' ${WRKSRC}/cmake/XercesNetAccessorSelection.cmake
-
-post-patch-DOCS-off:
- @${REINPLACE_CMD} -e '/add_subdirectory(doc)/d' ${WRKSRC}/CMakeLists.txt
-
+ ${REINPLACE_CMD} -e "s,@DEFS@,& -D__STDC_LIMIT_MACROS," ${WRKSRC}/src/Makefile.in
+
post-install:
${LN} -s libxerces-c-${PORTVERSION:R}.so ${STAGEDIR}${PREFIX}/lib/libxerces-c.so.${PORTVERSION:R:R}