aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xlhtml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/xlhtml/Makefile')
-rw-r--r--textproc/xlhtml/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/textproc/xlhtml/Makefile b/textproc/xlhtml/Makefile
index e11b6d8b1938..6bd075a41395 100644
--- a/textproc/xlhtml/Makefile
+++ b/textproc/xlhtml/Makefile
@@ -12,20 +12,22 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert Excel and PowerPoint files to HTML and text
-USE_GMAKE= yes
+LICENSE= GPLv2
+
+USES= gmake
+
USE_AUTOTOOLS= automake14 autoconf
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
-NO_STAGE= yes
-MAN1= ppthtml.1 xlhtml.1
+OPTIONS_DEFINE= DOCS
-.if !defined(NOPORTDOCS)
post-install:
.for dir in xlhtml ppthtml
- @${MKDIR} ${DOCSDIR}/${dir}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/${dir}
cd ${WRKSRC}/${dir} && \
- ${INSTALL_DATA} ChangeLog README THANKS ${DOCSDIR}/${dir}
+ ${INSTALL_DATA} ChangeLog README THANKS \
+ ${STAGEDIR}${DOCSDIR}/${dir}
.endfor
-.endif
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xlhtml \
+ ${STAGEDIR}${PREFIX}/bin/ppthtml
.include <bsd.port.mk>