aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/uim-gnome/Makefile4
-rw-r--r--textproc/uim-gtk/Makefile4
-rw-r--r--textproc/uim-m17nlib/Makefile10
-rw-r--r--textproc/uim-qt/Makefile4
-rw-r--r--textproc/uim/Makefile29
-rw-r--r--textproc/uim/pkg-plist4
6 files changed, 46 insertions, 9 deletions
diff --git a/textproc/uim-gnome/Makefile b/textproc/uim-gnome/Makefile
index 5f936e2693dc..f7e268412d00 100644
--- a/textproc/uim-gnome/Makefile
+++ b/textproc/uim-gnome/Makefile
@@ -20,6 +20,10 @@ UIM_SLAVE= yes
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-helper_Makefile.in
+.if defined(WITHOUT_X11)
+IGNORE= requires X11
+.endif
+
do-build:
(cd ${WRKSRC}/helper && ${GMAKE} LIBS="-luim -luim-custom")
diff --git a/textproc/uim-gtk/Makefile b/textproc/uim-gtk/Makefile
index 98aec34e26cd..6f3d8268f7f9 100644
--- a/textproc/uim-gtk/Makefile
+++ b/textproc/uim-gtk/Makefile
@@ -21,6 +21,10 @@ UIM_SLAVE= yes
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-gtk_Makefile.in \
${PATCHDIR}/extra-patch-helper_Makefile.in
+.if defined(WITHOUT_X11)
+IGNORE= requires X11
+.endif
+
do-build:
(cd ${WRKSRC}/gtk && ${GMAKE} LIBS="-luim")
(cd ${WRKSRC}/helper && ${GMAKE} LIBS="-luim -luim-custom")
diff --git a/textproc/uim-m17nlib/Makefile b/textproc/uim-m17nlib/Makefile
index dbe18c204187..a7345bb7fc60 100644
--- a/textproc/uim-m17nlib/Makefile
+++ b/textproc/uim-m17nlib/Makefile
@@ -5,7 +5,11 @@
# $FreeBSD$
#
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -m17nlib-nox11
+.else
PKGNAMESUFFIX= -m17nlib
+.endif
COMMENT= Uim plugin using m17n library input method
@@ -28,6 +32,10 @@ do-install:
${GMAKE} uim_plugin_LTLIBRARIES=libuim-m17nlib.la install-uim_pluginLTLIBRARIES)
post-install:
- ${X11BASE}/bin/uim-module-manager --register m17nlib
+.if defined(WITHOUT_X11)
+ ${LOCALBASE}/bin/uim-module-manager --register anthy
+.else
+ ${X11BASE}/bin/uim-module-manager --register anthy
+.endif
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/uim-qt/Makefile b/textproc/uim-qt/Makefile
index a7a6d96bf273..6e3ead0ac76b 100644
--- a/textproc/uim-qt/Makefile
+++ b/textproc/uim-qt/Makefile
@@ -30,6 +30,10 @@ CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-qt_Makefile.in
+.if defined(WITHOUT_X11)
+IGNORE= requires X11
+.endif
+
do-build:
(cd ${WRKSRC}/qt && ${GMAKE} LIBS="-luim -luim-custom")
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 0c6a892c736e..eccbb76e74d8 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -9,36 +9,53 @@ PORTNAME= uim
PORTVERSION= 1.1.1
CATEGORIES?= textproc
MASTER_SITES= http://uim.freedesktop.org/releases/
+.if !defined(UIM_SLAVE) && defined(WITHOUT_X11)
+PKGNAMESUFFIX= -nox11
+.endif
MAINTAINER= nobutaka@FreeBSD.org
COMMENT?= Input method library
-USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
WANT_GNOME= yes
USE_GNOME+= gnometarget glib20
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
+USE_GETTEXT= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-.if !defined(UIM_SLAVE)
-USE_GNOME+= gtk20
-.endif
+.if !defined(WITHOUT_X11)
+USE_X_PREFIX= yes
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+= --with-x --with-xft
+.endif
.if !defined(UIM_SLAVE)
-CONFIGURE_ARGS= --enable-emacs --with-gtk2
+.if !defined(WITHOUT_X11)
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+= --with-gtk2
+.endif
+CONFIGURE_ARGS+= --enable-emacs
.endif
+
CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
.if !defined(UIM_SLAVE)
+.if !defined(WITHOUT_X11)
MAN1= uim-xim.1
+.endif
DOCSDIR_JA= ${PREFIX}/share/doc/ja/uim
PLIST_SUB= DOCSDIR_JA="${DOCSDIR_JA:S,^${PREFIX}/,,}"
.endif
+.if defined(WITHOUT_X11)
+PLIST_SUB+= X11="@comment "
+.else
+PLIST_SUB+= X11=""
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
@@ -52,7 +69,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/perl:${PORTSDIR}/lang/perl5
CONFIGURE_ENV+= INTLTOOL_PERL="${LOCALBASE}/bin/perl"
.endif
-.for _x in gtk2 qt gnome2 anthy canna m17nlib prime scim dict
+.for _x in x xft gtk2 qt gnome2 anthy canna m17nlib prime scim dict
.if ${CONFIGURE_ARGS:M--with-${_x}} == ""
CONFIGURE_ARGS+=--without-${_x}
.endif
diff --git a/textproc/uim/pkg-plist b/textproc/uim/pkg-plist
index 75a1ef6e7cfc..b672612753ff 100644
--- a/textproc/uim/pkg-plist
+++ b/textproc/uim/pkg-plist
@@ -4,7 +4,7 @@ bin/uim-fep
bin/uim-fep-tick
bin/uim-module-manager
bin/uim-sh
-bin/uim-xim
+%%X11%%bin/uim-xim
include/uim/plugin.h
include/uim/uim-compat-scm.h
include/uim/uim-custom.h
@@ -28,7 +28,7 @@ lib/uim/plugin/libuim-skk.a
lib/uim/plugin/libuim-skk.la
lib/uim/plugin/libuim-skk.so
libdata/pkgconfig/uim.pc
-libexec/uim-candwin-gtk
+%%X11%%libexec/uim-candwin-gtk
libexec/uim-helper-server
share/applications/uim.desktop
share/locale/fr/LC_MESSAGES/uim.mo