aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ispell/Makefile4
-rw-r--r--textproc/libxml/Makefile3
2 files changed, 5 insertions, 2 deletions
diff --git a/textproc/ispell/Makefile b/textproc/ispell/Makefile
index 96dbb8c4392f..5cc53b844ad8 100644
--- a/textproc/ispell/Makefile
+++ b/textproc/ispell/Makefile
@@ -21,6 +21,8 @@ MAN4= ispell.4 english.4
MLINKS= ispell.1 buildhash.1 ispell.1 findaffix.1 ispell.1 \
munchlist.1 ispell.1 tryaffix.1
+USE_REINPLACE= yes
+
EXTRACT_ONLY= ${ISPELL_FILES}
EXTRA_DICT=
MAKE_FLAGS= TMPDIR=${WRKDIR} -f
@@ -173,7 +175,7 @@ post-extract:
post-patch:
.if defined(ISPELL_IT)
@cd ${WRKDIR} && ${PATCH} < ${FILESDIR}/IT.patch 2>/dev/null
- @${PERL} -pi -e "s|%%BH%%|${BUILDHASH}|g;s|%%MH%%|${MUNCHLIST}|g" \
+ @${REINPLACE_CMD} -e "s|%%BH%%|${BUILDHASH}|g;s|%%MH%%|${MUNCHLIST}|g" \
${WRKDIR}/ispell-it/Makefile
.endif
.if defined(ISPELL_FR)
diff --git a/textproc/libxml/Makefile b/textproc/libxml/Makefile
index 09f42dab1e16..70fbd7c7d6c5 100644
--- a/textproc/libxml/Makefile
+++ b/textproc/libxml/Makefile
@@ -18,11 +18,12 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
pre-patch:
- @find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "*.[ch]" | xargs ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
.include <bsd.port.mk>