aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/nux/Makefile69
-rw-r--r--textproc/nux/distinfo2
-rw-r--r--textproc/nux/files/fire-validate.sh5
-rw-r--r--textproc/nux/pkg-descr20
5 files changed, 97 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 45b434bd801f..867b20c1d68f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -233,6 +233,7 @@
SUBDIR += nltk
SUBDIR += nn-aspell
SUBDIR += nunnimcax
+ SUBDIR += nux
SUBDIR += ny-aspell
SUBDIR += ocaml-pxp
SUBDIR += ocaml-yaxi
diff --git a/textproc/nux/Makefile b/textproc/nux/Makefile
new file mode 100644
index 000000000000..cff1f0dbfc35
--- /dev/null
+++ b/textproc/nux/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: nux
+# Date created: 2004-10-28
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nux
+PORTVERSION= 1.0a5
+CATEGORIES= textproc java
+MASTER_SITES= http://dsd.lbl.gov/nux-download/snapshots/
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Small open-source XQuery extension of the XOM library
+
+RUN_DEPENDS= ${JAVALIBDIR}/xom.jar:${PORTSDIR}/textproc/xom \
+ ${JAVALIBDIR}/saxon8.jar:${PORTSDIR}/textproc/saxon-devel
+
+OPTIONS= VALIDATION_TOOL "Install the XML Schema validation tool" on
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_VALIDATION_TOOL)
+RUN_DEPENDS+= ${JAVALIBDIR}/getopt.jar:${PORTSDIR}/java/java-getopt \
+ classpath:${PORTSDIR}/java/javavmwrapper
+VALIDATION_TOOL=fire-validate
+.endif
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+.if defined(WITH_VALIDATION_TOOL)
+PLIST_FILES+= bin/${VALIDATION_TOOL}
+.endif
+.if !defined(NOPORTDOCS)
+PORTDOCS= api bugs.html changelog.html cvs.html dependencies.html \
+ gettingstarted.html images index.html install.html \
+ license.html licenses mailing.html readme.html \
+ relatedwork.html style.css todo.html tutorials.html
+.endif
+
+.if defined(WITH_VALIDATION_TOOL)
+do-configure:
+ ${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},g ; s,%%JAVA%%,${JAVA},g' \
+ ${FILESDIR}/${VALIDATION_TOOL}.sh >${WRKSRC}/${VALIDATION_TOOL}
+.endif
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}.jar ${JAVAJARDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.if defined(WITH_VALIDATION_TOOL)
+ @${ECHO_MSG} -n ">> Installing validation tool as ${PREFIX}/bin/${VALIDATION_TOOL}..."
+ @${INSTALL_SCRIPT} ${WRKSRC}/${VALIDATION_TOOL} ${PREFIX}/bin/
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc/ && ${FIND} ${PORTDOCS} \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/nux/distinfo b/textproc/nux/distinfo
new file mode 100644
index 000000000000..3cd88374fe92
--- /dev/null
+++ b/textproc/nux/distinfo
@@ -0,0 +1,2 @@
+MD5 (nux-1.0a5.tar.gz) = 022ed45119bd6ddb039bc1f3acf1c997
+SIZE (nux-1.0a5.tar.gz) = 1235038
diff --git a/textproc/nux/files/fire-validate.sh b/textproc/nux/files/fire-validate.sh
new file mode 100644
index 000000000000..5f8c5acf1fda
--- /dev/null
+++ b/textproc/nux/files/fire-validate.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+exec %%JAVA%% -classpath "`%%LOCALBASE%%/bin/classpath`" nux.xom.tests.ValidationCommand $*
diff --git a/textproc/nux/pkg-descr b/textproc/nux/pkg-descr
new file mode 100644
index 000000000000..a216c7f3a64f
--- /dev/null
+++ b/textproc/nux/pkg-descr
@@ -0,0 +1,20 @@
+Nux is a small, straightforward, and surprisingly effective open-source
+extension of the XOM XML library. Nux is geared towards versatile embedded
+integration and interchange, in particular for high-throughput server container
+environments (e.g. large-scale Peer-to-Peer messaging network infrastructures
+over high-bandwidth networks, scalable MOMs, etc). But its simplicity also
+makes it useful for client side XML query/transformation workflow pipelines.
+Features include:
+
+- Seamless W3C XQuery support for XOM.
+- Efficient and flexible pools and factories for XQueries, XSL Transforms, as
+ well as Builders that validate against various schema languages, including
+ W3C XML Schemas, DTDs, RELAX NG, Schematron, etc.
+- For simple and complex continuous queries and/or transformations over very
+ large or infinitely long XML input, a convenient streaming path filter API
+ combines full XQuery support with straightforward filtering.
+- Glue for integration with JAXB and for queries over ill-formed HTML.
+- All this is rock-solid, dependable, well documented, and ships in a jar file
+ that weighs just 60 KB.
+
+WWW: http://dsd.lbl.gov/nux/