aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Apache-Solr/Makefile17
-rw-r--r--textproc/p5-Apache-Solr/distinfo3
-rw-r--r--textproc/p5-Apache-Solr/pkg-descr3
-rw-r--r--textproc/p5-Apache-Solr/pkg-plist16
5 files changed, 40 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 80cd1bf38f9d..217d5bc62df6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -528,6 +528,7 @@
SUBDIR += p5-Algorithm-CheckDigits
SUBDIR += p5-Algorithm-RabinKarp
SUBDIR += p5-Apache-ParseLog
+ SUBDIR += p5-Apache-Solr
SUBDIR += p5-BibTeX-Parser
SUBDIR += p5-Bloom-Filter
SUBDIR += p5-CAM-PDF
diff --git a/textproc/p5-Apache-Solr/Makefile b/textproc/p5-Apache-Solr/Makefile
new file mode 100644
index 000000000000..78193ea81fa8
--- /dev/null
+++ b/textproc/p5-Apache-Solr/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= Apache-Solr
+PORTVERSION= 1.04
+CATEGORIES= textproc www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= High level interface to the Solr server
+
+LICENSE= ART10
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Apache-Solr/distinfo b/textproc/p5-Apache-Solr/distinfo
new file mode 100644
index 000000000000..7127ed39ff92
--- /dev/null
+++ b/textproc/p5-Apache-Solr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1497626195
+SHA256 (Apache-Solr-1.04.tar.gz) = 9ae71d8c5a6783e1f6a7682529071cbbbd279eeb422876f8f3babf0f82c7e8df
+SIZE (Apache-Solr-1.04.tar.gz) = 42162
diff --git a/textproc/p5-Apache-Solr/pkg-descr b/textproc/p5-Apache-Solr/pkg-descr
new file mode 100644
index 000000000000..89557c8dc5da
--- /dev/null
+++ b/textproc/p5-Apache-Solr/pkg-descr
@@ -0,0 +1,3 @@
+Apache::Solr provides an high level interface to access solr servers.
+
+WWW: http://search.cpan.org/dist/Apache-Solr/
diff --git a/textproc/p5-Apache-Solr/pkg-plist b/textproc/p5-Apache-Solr/pkg-plist
new file mode 100644
index 000000000000..1b915d1a03fd
--- /dev/null
+++ b/textproc/p5-Apache-Solr/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Apache/Solr.pm
+%%SITE_PERL%%/Apache/Solr.pod
+%%SITE_PERL%%/Apache/Solr/Document.pm
+%%SITE_PERL%%/Apache/Solr/Document.pod
+%%SITE_PERL%%/Apache/Solr/JSON.pm
+%%SITE_PERL%%/Apache/Solr/JSON.pod
+%%SITE_PERL%%/Apache/Solr/Result.pm
+%%SITE_PERL%%/Apache/Solr/Result.pod
+%%SITE_PERL%%/Apache/Solr/Tables.pm
+%%SITE_PERL%%/Apache/Solr/XML.pm
+%%SITE_PERL%%/Apache/Solr/XML.pod
+%%PERL5_MAN3%%/Apache::Solr.3.gz
+%%PERL5_MAN3%%/Apache::Solr::Document.3.gz
+%%PERL5_MAN3%%/Apache::Solr::JSON.3.gz
+%%PERL5_MAN3%%/Apache::Solr::Result.3.gz
+%%PERL5_MAN3%%/Apache::Solr::XML.3.gz