aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile2
-rw-r--r--textproc/xxdiff-scripts/Makefile22
-rw-r--r--textproc/xxdiff-scripts/distinfo2
-rw-r--r--textproc/xxdiff-scripts/pkg-descr15
-rw-r--r--textproc/xxdiff/Makefile47
-rw-r--r--textproc/xxdiff/distinfo2
-rw-r--r--textproc/xxdiff/pkg-descr22
7 files changed, 112 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ff8a40db45c4..2c82a02a1d72 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1688,6 +1688,8 @@
SUBDIR += xsv
SUBDIR += xt
SUBDIR += xwindiff
+ SUBDIR += xxdiff
+ SUBDIR += xxdiff-scripts
SUBDIR += y2l
SUBDIR += yali
SUBDIR += yamcha
diff --git a/textproc/xxdiff-scripts/Makefile b/textproc/xxdiff-scripts/Makefile
new file mode 100644
index 000000000000..74c862c40746
--- /dev/null
+++ b/textproc/xxdiff-scripts/Makefile
@@ -0,0 +1,22 @@
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xxdiff
+PORTVERSION= 4.0
+CATEGORIES= textproc
+MASTER_SITES= SF
+PKGNAMESUFFIX= -scripts
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Helper scripts for xxdiff
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= xxdiff:${PORTSDIR}/textproc/xxdiff
+
+USES= python:2 tar:bzip2
+USE_PYTHON= autoplist distutils
+PYDISTUTILS_PKGNAME= xxdiff-scripts
+
+.include <bsd.port.mk>
diff --git a/textproc/xxdiff-scripts/distinfo b/textproc/xxdiff-scripts/distinfo
new file mode 100644
index 000000000000..b13cc70234aa
--- /dev/null
+++ b/textproc/xxdiff-scripts/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xxdiff-4.0.tar.bz2) = 91501544e82bc89983d07eeb086419645fbfa78fc906b50ff7ab6cdf39431330
+SIZE (xxdiff-4.0.tar.bz2) = 1768460
diff --git a/textproc/xxdiff-scripts/pkg-descr b/textproc/xxdiff-scripts/pkg-descr
new file mode 100644
index 000000000000..5d072da38865
--- /dev/null
+++ b/textproc/xxdiff-scripts/pkg-descr
@@ -0,0 +1,15 @@
+xxdiff is a computer program that allows a user (usually a software
+developer of some sort) to easily visualize the differences between
+files. The manner and goal for which this process is applied over
+multiple files is highly dependent on the application, and most of
+the time is driven by custom user scripts.
+
+For example, a configuration management engineer in a company might
+provide some kind of merge policing environment, that allows software
+developers to review changes in files for the purpose of accepting or
+rejecting a submitted changeset to a codebase. Another example is
+that of a developer wishing to review the changes he made to a
+checkout of files from a source-code management system such as CVS,
+Subversion, ClearCase, Perforce, etc.
+
+WWW: http://furius.ca/xxdiff/doc/xxdiff-scripts.html
diff --git a/textproc/xxdiff/Makefile b/textproc/xxdiff/Makefile
new file mode 100644
index 000000000000..962917f3f9c9
--- /dev/null
+++ b/textproc/xxdiff/Makefile
@@ -0,0 +1,47 @@
+# Created by: Pete Fritchman <petef@databits.net>
+# $FreeBSD$
+
+PORTNAME= xxdiff
+PORTVERSION= 4.0
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Graphical file and directories comparator and merge tool
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= bison gmake tar:bz2
+USE_QT4= gui moc_build qmake_build uic_build
+
+BUILD_WRKSRC= ${WRKSRC}/src
+
+PLIST_FILES= bin/xxdiff
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.pre.mk>
+
+# base flex(1) v2.5.4 is not sufficient
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000033
+BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+
+post-patch:
+ @${REINPLACE_CMD} -e 's!flex!${LOCALBASE}/bin/&!' \
+ ${BUILD_WRKSRC}/xxdiff.pro
+.endif
+
+pre-build:
+ @(cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} QMAKE=${QMAKE} \
+ ${MAKE_CMD} -f Makefile.bootstrap ${MAKE_ARGS} Makefile)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/xxdiff ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "${PORTDOCS} ! -name Makefile" \
+ ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/xxdiff/distinfo b/textproc/xxdiff/distinfo
new file mode 100644
index 000000000000..b13cc70234aa
--- /dev/null
+++ b/textproc/xxdiff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xxdiff-4.0.tar.bz2) = 91501544e82bc89983d07eeb086419645fbfa78fc906b50ff7ab6cdf39431330
+SIZE (xxdiff-4.0.tar.bz2) = 1768460
diff --git a/textproc/xxdiff/pkg-descr b/textproc/xxdiff/pkg-descr
new file mode 100644
index 000000000000..612c5c1b6376
--- /dev/null
+++ b/textproc/xxdiff/pkg-descr
@@ -0,0 +1,22 @@
+xxdiff is a graphical tool for viewing the differences between two or three
+files, or between two directories, and can produce a merged version thereof.
+
+Some of its features:
+
+ - Comparing two files, three files, or two directories (shallow and
+ recursive)
+ - Horizontal diffs highlighting
+ - Files can be merged interactively and resulting output visualized
+ and saved
+ - Has features to assist in performing merge reviews/policing
+ - Can unmerge CVS conflicts in automatically merged file and display
+ them as two files, to help resolve conflicts
+ - Uses external diff program to compute differences: works with GNU
+ diff, SGI diff and ClearCase's cleardiff, and any other diff whose
+ output is similar to those
+ - Fully customizable with a resource file
+ - Look-and-feel similar to Rudy Wortel's/SGI xdiff; it is desktop
+ agnostic (i.e. will work equally well with KDE or GNOME)
+ - Features and output that ease integration with scripts
+
+WWW: http://furius.ca/xxdiff/