aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile2
-rw-r--r--textproc/py-alabaster/Makefile17
-rw-r--r--textproc/py-alabaster/distinfo2
-rw-r--r--textproc/py-alabaster/pkg-descr4
-rw-r--r--textproc/py-snowballstemmer/Makefile17
-rw-r--r--textproc/py-snowballstemmer/distinfo2
-rw-r--r--textproc/py-snowballstemmer/pkg-descr4
7 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 58657733130d..64fc6c69d275 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1171,6 +1171,7 @@
SUBDIR += py-MarkupSafe
SUBDIR += py-Tempita
SUBDIR += py-acora
+ SUBDIR += py-alabaster
SUBDIR += py-asciinema
SUBDIR += py-asv
SUBDIR += py-bugzillatools
@@ -1231,6 +1232,7 @@
SUBDIR += py-rstyoutube
SUBDIR += py-rxp
SUBDIR += py-sgrep
+ SUBDIR += py-snowballstemmer
SUBDIR += py-sparqlwrapper
SUBDIR += py-sphinx
SUBDIR += py-sphinx-intl
diff --git a/textproc/py-alabaster/Makefile b/textproc/py-alabaster/Makefile
new file mode 100644
index 000000000000..03323eb85de1
--- /dev/null
+++ b/textproc/py-alabaster/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= alabaster
+PORTVERSION= 0.7.6
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= Modified Kr Sphinx theme
+
+LICENSE= MIT
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/textproc/py-alabaster/distinfo b/textproc/py-alabaster/distinfo
new file mode 100644
index 000000000000..3671b689caa7
--- /dev/null
+++ b/textproc/py-alabaster/distinfo
@@ -0,0 +1,2 @@
+SHA256 (alabaster-0.7.6.tar.gz) = 309d33e0282c8209f792f3527f41ec04e508ff837c61fc1906dde988a256deeb
+SIZE (alabaster-0.7.6.tar.gz) = 16598
diff --git a/textproc/py-alabaster/pkg-descr b/textproc/py-alabaster/pkg-descr
new file mode 100644
index 000000000000..6af0f8757061
--- /dev/null
+++ b/textproc/py-alabaster/pkg-descr
@@ -0,0 +1,4 @@
+Based off the original Flask and KR themes, this is a more
+extensible version of the prior.
+
+WWW: https://github.com/bitprophet/alabaster
diff --git a/textproc/py-snowballstemmer/Makefile b/textproc/py-snowballstemmer/Makefile
new file mode 100644
index 000000000000..fdd1d18231ef
--- /dev/null
+++ b/textproc/py-snowballstemmer/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= snowballstemmer
+PORTVERSION= 1.2.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= Pure Python stemming library
+
+LICENSE= MIT
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/textproc/py-snowballstemmer/distinfo b/textproc/py-snowballstemmer/distinfo
new file mode 100644
index 000000000000..601847e57c64
--- /dev/null
+++ b/textproc/py-snowballstemmer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (snowballstemmer-1.2.0.tar.gz) = 6d54f350e7a0e48903a4e3b6b2cabd1b43e23765fbc975065402893692954191
+SIZE (snowballstemmer-1.2.0.tar.gz) = 49639
diff --git a/textproc/py-snowballstemmer/pkg-descr b/textproc/py-snowballstemmer/pkg-descr
new file mode 100644
index 000000000000..b655bea35195
--- /dev/null
+++ b/textproc/py-snowballstemmer/pkg-descr
@@ -0,0 +1,4 @@
+This is a pure Python stemming library. If PyStemmer is
+available, this module uses it to accelerate.
+
+WWW: https://pypi.python.org/pypi/snowballstemmer