aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ruby-libxml/Makefile8
-rw-r--r--textproc/ruby-xtemplate/Makefile8
-rw-r--r--textproc/xmlwrapp/Makefile4
3 files changed, 18 insertions, 2 deletions
diff --git a/textproc/ruby-libxml/Makefile b/textproc/ruby-libxml/Makefile
index a94cd856e42c..4cc3ddae767f 100644
--- a/textproc/ruby-libxml/Makefile
+++ b/textproc/ruby-libxml/Makefile
@@ -26,4 +26,10 @@ USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/ruby-xtemplate/Makefile b/textproc/ruby-xtemplate/Makefile
index 69ad3f2d494f..c3f55ed3e231 100644
--- a/textproc/ruby-xtemplate/Makefile
+++ b/textproc/ruby-xtemplate/Makefile
@@ -26,6 +26,12 @@ CONFIGURE_ARGS= --with-ext
DOCS_EN= CHANGES README STATUS TUTORIAL
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -36,4 +42,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index 5c5af810dea3..b8d678e88012 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -27,6 +27,10 @@ CFLAGS+= -fPIC
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
.if ${HAVE_GNOME:Mlibxslt}!=""
USE_GNOME+= libxslt
.else