aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/bsdgrep/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/textproc/bsdgrep/Makefile b/textproc/bsdgrep/Makefile
index a1d5f686e035..44d019d5b5f4 100644
--- a/textproc/bsdgrep/Makefile
+++ b/textproc/bsdgrep/Makefile
@@ -37,8 +37,9 @@ MAKE_ENV+= BINDIR="${PREFIX}/bin" \
CATDIR="${MANPREFIX}/man/man" \
NLSDIR="${PREFIX}/share/nls"
-OPTIONS= NLS "Compile with NLS support" on \
- GNU_COMPAT "Use GNU regex library (recommended)" on
+OPTIONS_DEFINE= GNU_COMPAT
+OPTIONS_DEFAULT= GNU_COMPAT
+GNU_COMPAT_DESC= Use GNU regex library (recommended)
CONFLICTS= gnugrep-*
@@ -51,19 +52,19 @@ LDFLAGS+= -L${LOCALBASE}/lib
BROKEN= overwrites files installed by dependency
.endif
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
MAKE_ENV+= WITHOUT_NLS=yes
PLIST_SUB+= NLS="@comment "
.else
PLIST_SUB+= NLS=""
.endif
-.if defined(WITHOUT_GNU_COMPAT)
+.if !${PORT_OPTIONS:MGNU_COMPAT}
MAKE_ENV+= WITHOUT_GNU_COMPAT=yes
.endif
pre-install:
-.if defined(WITH_NLS)
+.if ${PORT_OPTIONS:MNLS}
${MKDIR} ${LOCALBASE}/share/nls/gl_ES.ISO8859-1
.endif