aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxslt/Makefile1
-rw-r--r--textproc/libxslt/files/patch-libxslt::transform.c16
2 files changed, 17 insertions, 0 deletions
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index e20472895a1a..56bd4c2aa52d 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libxslt
PORTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/libxslt
diff --git a/textproc/libxslt/files/patch-libxslt::transform.c b/textproc/libxslt/files/patch-libxslt::transform.c
new file mode 100644
index 000000000000..28c33664dbda
--- /dev/null
+++ b/textproc/libxslt/files/patch-libxslt::transform.c
@@ -0,0 +1,16 @@
+--- libxslt/transform.c.orig Sat Nov 10 13:35:49 2001
++++ libxslt/transform.c Mon Dec 3 00:03:39 2001
+@@ -3474,12 +3474,10 @@
+ if (tmp == root) {
+ ctxt->type = XSLT_OUTPUT_HTML;
+ res->type = XML_HTML_DOCUMENT_NODE;
+- if (((doctypePublic != NULL) || (doctypeSystem != NULL)))
++ if (((doctypePublic != NULL) || (doctypeSystem != NULL))) {
+ res->intSubset = xmlCreateIntSubset(res, root->name,
+ doctypePublic,
+ doctypeSystem);
+- if (((doctypePublic != NULL) || (doctypeSystem != NULL))) {
+- res = htmlNewDoc(doctypeSystem, doctypePublic);
+ #ifdef XSLT_GENERATE_HTML_DOCTYPE
+ } else if (version != NULL) {
+ xsltGetHTMLIDs(version, &doctypePublic,