aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/grap/Makefile8
-rw-r--r--textproc/isearch/Makefile8
-rw-r--r--textproc/sp/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/textproc/grap/Makefile b/textproc/grap/Makefile
index 361e865a1056..f0c194eddfff 100644
--- a/textproc/grap/Makefile
+++ b/textproc/grap/Makefile
@@ -17,9 +17,15 @@ CONFIGURE_ARGS=--with-freebsd-ports
MAN1= grap.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500035
+BROKEN= "Does not compile on 5.0"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
cd ${WRKSRC} && make install-docs
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/isearch/Makefile b/textproc/isearch/Makefile
index 9797cae44702..ab5a316377d7 100644
--- a/textproc/isearch/Makefile
+++ b/textproc/isearch/Makefile
@@ -16,10 +16,16 @@ MAINTAINER= pmarquis@pobox.com
GNU_CONFIGURE= yes
MAKE_ARGS= INSTALL=${PREFIX}/bin
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500035
+BROKEN= "Does not compile on 5.0"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/html/*.html ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/sp/Makefile b/textproc/sp/Makefile
index 51ec20618e07..7bba5b46375b 100644
--- a/textproc/sp/Makefile
+++ b/textproc/sp/Makefile
@@ -15,6 +15,12 @@ MAINTAINER= chuckr@FreeBSD.org
USE_SUBMAKE= yes
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500035
+BROKEN= "Does not compile on 5.0"
+.endif
+
post-patch:
$(CP) $(WRKSRC)/Makefile $(WRKSRC)/Makefile.sed
$(CP) $(WRKSRC)/Makefile.lib $(WRKSRC)/Makefile.lib.sed
@@ -28,4 +34,4 @@ post-install:
for file in $(WRKSRC)/include/*;do $(INSTALL_DATA) $$file $(PREFIX)/include/sp;done
for file in $(WRKSRC)/doc/*;do $(INSTALL_DATA) $$file $(PREFIX)/share/doc/sp;done
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>