aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libroxml/Makefile15
-rw-r--r--textproc/libroxml/files/patch-Makefile16
2 files changed, 20 insertions, 11 deletions
diff --git a/textproc/libroxml/Makefile b/textproc/libroxml/Makefile
index c9a10b2e1cad..94a86257f9da 100644
--- a/textproc/libroxml/Makefile
+++ b/textproc/libroxml/Makefile
@@ -3,30 +3,31 @@
PORTNAME= libroxml
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= GOOGLE_CODE
MAINTAINER= gaod@hychen.org
-COMMENT= A minimum, easy-to-use, C implementation for xml file parsing
+COMMENT= Minimum, easy-to-use, C implementation for xml file parsing
LICENSE= LGPL21
PROJECTHOST= libroxml
-USE_GMAKE= yes
-MAKE_ENV+= DESTDIR=${PREFIX}
+USES= gmake
+# Workaround overwriting DESTDIR var
+DESTDIRNAME= NONE
+MAKE_ARGS= DESTDIR=${STAGEDIR}${PREFIX}
USE_LDCONFIG= yes
-MAN1= roxml.1
-
PLIST_FILES= bin/roxml \
lib/libroxml.so \
lib/libroxml.so.0 \
lib/libroxml.a \
include/roxml.h \
- libdata/pkgconfig/libroxml.pc
+ libdata/pkgconfig/libroxml.pc \
+ man/man1/roxml.1.gz
-NO_STAGE= yes
pre-build:
@cd ${WRKSRC} && ${GMAKE} clean
diff --git a/textproc/libroxml/files/patch-Makefile b/textproc/libroxml/files/patch-Makefile
index 6a8589b7753f..d4545e83a3e6 100644
--- a/textproc/libroxml/files/patch-Makefile
+++ b/textproc/libroxml/files/patch-Makefile
@@ -1,9 +1,17 @@
---- Makefile.orig 2012-08-07 05:07:01.000000000 +0800
-+++ Makefile 2012-08-07 05:12:48.000000000 +0800
+--- Makefile.orig 2013-06-07 22:26:58.000000000 +0000
++++ Makefile 2013-09-19 18:58:18.000000000 +0000
+@@ -44,7 +44,7 @@
+
+ # options
+ override CPPFLAGS += -Iinc/
+-override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused -Werror -Iinc/ $(DEFINES)
++override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused -Iinc/ $(DEFINES)
+ override LDFLAGS +=
+
+ ifeq ("$(OS)", "Darwin")
@@ -149,24 +149,16 @@
$E - $(MAKE) -C $(abspath fuse.xml)
-
- .PHONY: install
+ .PHONY: install
-install: $(TARGETS) doxy
- $P ' INSTALL DIRS'
- $E mkdir -p $(DESTDIR)/usr/bin