aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/uim-qt/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/textproc/uim-qt/Makefile b/textproc/uim-qt/Makefile
index b23df1126d56..0666f024eb2e 100644
--- a/textproc/uim-qt/Makefile
+++ b/textproc/uim-qt/Makefile
@@ -20,8 +20,16 @@ CONFIGURE_ENV= QTDIR=${X11BASE}/lib QTINCDIR=${X11BASE}/include \
UIM_SLAVE= yes
+# This is normally handled by defining USE_QT_VER ...
+
+.if defined(PACKAGE_BUILDING)
+TMPDIR?= /tmp
+MAKE_ENV+= TMPDIR="${TMPDIR}"
+CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
+.endif
+
do-install:
- (cd ${WRKSRC}/qt && ${GMAKE} install)
- (cd ${WRKSRC}/helper && ${GMAKE} install)
+ (cd ${WRKSRC}/qt && ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+ (cd ${WRKSRC}/helper && ${SETENV} ${MAKE_ENV} ${GMAKE} install)
.include "${MASTERDIR}/Makefile"