aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libwps02/Makefile37
-rw-r--r--textproc/libwps02/distinfo2
-rw-r--r--textproc/libwps02/pkg-descr7
-rw-r--r--textproc/libwps02/pkg-plist7
5 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 80dda1393add..e5c3a4ba3df7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -394,6 +394,7 @@
SUBDIR += libwpd
SUBDIR += libwpd010
SUBDIR += libwps
+ SUBDIR += libwps02
SUBDIR += libwps03
SUBDIR += libxdiff
SUBDIR += libxml++26
diff --git a/textproc/libwps02/Makefile b/textproc/libwps02/Makefile
new file mode 100644
index 000000000000..d44c5386e9ac
--- /dev/null
+++ b/textproc/libwps02/Makefile
@@ -0,0 +1,37 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libwps
+PORTVERSION= 0.2.9
+CATEGORIES= textproc
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+PKGNAMESUFFIX= 02
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Microsoft file word processor format import filter library
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libwpd-0.9.so:${PORTSDIR}/textproc/libwpd
+
+CONFIGURE_ARGS= --disable-werror --without-docs
+CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+USES= compiler:features libtool:keepla pathfix pkgconfig
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_FEATURES:Mlibc++}
+CONFIGURE_ARGS+= --with-sharedptr=c++11
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+CONFIGURE_ARGS+= --with-sharedptr=boost
+.endif
+
+post-stage:
+ @${RM} -f ${STAGEDIR}${PREFIX}/bin/*
+
+.include <bsd.port.post.mk>
diff --git a/textproc/libwps02/distinfo b/textproc/libwps02/distinfo
new file mode 100644
index 000000000000..ddf67d0fa80e
--- /dev/null
+++ b/textproc/libwps02/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libwps-0.2.9.tar.gz) = de57e3eb91eb1c6b9c6f1a765f943a3ac894e7575fad117a88ab7959fc29256d
+SIZE (libwps-0.2.9.tar.gz) = 615767
diff --git a/textproc/libwps02/pkg-descr b/textproc/libwps02/pkg-descr
new file mode 100644
index 000000000000..b9fabb298083
--- /dev/null
+++ b/textproc/libwps02/pkg-descr
@@ -0,0 +1,7 @@
+Libwps is a library (for use by word procesors, for example) for importing the
+Microsoft Works word processor file format. It imports Works format versions 2,
+3, 4, 5 (aka 2000), and 8 with some formatting. The scope of this project is
+just a Works word processor import filter, so there are no plans for supporting
+an export filter, spreadsheets, or databases.
+
+WWW: http://libwps.sourceforge.net/
diff --git a/textproc/libwps02/pkg-plist b/textproc/libwps02/pkg-plist
new file mode 100644
index 000000000000..dac0556fd621
--- /dev/null
+++ b/textproc/libwps02/pkg-plist
@@ -0,0 +1,7 @@
+include/libwps-0.2/libwps/WPSDocument.h
+include/libwps-0.2/libwps/libwps.h
+lib/libwps-0.2.la
+lib/libwps-0.2.so
+lib/libwps-0.2.so.2
+lib/libwps-0.2.so.2.0.9
+libdata/pkgconfig/libwps-0.2.pc