aboutsummaryrefslogtreecommitdiffstats
path: root/www/arena/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/arena/Makefile')
-rw-r--r--www/arena/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/arena/Makefile b/www/arena/Makefile
index 8a6e993b6971..68fcc94830cc 100644
--- a/www/arena/Makefile
+++ b/www/arena/Makefile
@@ -21,6 +21,12 @@ PLIST_FILES= bin/arena
USE_XLIB= yes
WRKSRC= ${WRKDIR}/WWW
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-build:
cd ${WRKSRC}/Library/freebsd; ${MAKE}
cd ${WRKSRC}/Arena/freebsd; \
@@ -33,4 +39,4 @@ do-install:
cd ${WRKSRC}/Arena/freebsd; \
${INSTALL} -c -m ${BINMODE} -o ${BINOWN} -g ${BINGRP} -s arena ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>