aboutsummaryrefslogtreecommitdiffstats
path: root/www/bozohttpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/bozohttpd/Makefile')
-rw-r--r--www/bozohttpd/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/www/bozohttpd/Makefile b/www/bozohttpd/Makefile
index 7695c2bf1f02..3e64b03ecacd 100644
--- a/www/bozohttpd/Makefile
+++ b/www/bozohttpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bozohttpd
-PORTVERSION= 20031005
+PORTVERSION= 20040218
CATEGORIES= www ipv6
MASTER_SITES= http://www.eterna.com.au/bozohttpd/
@@ -20,6 +20,19 @@ CFLAGS+= -DDO_HTPASSWD
MAKE_ARGS+= 'LDFLAGS+= -lcrypt'
.endif
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+CFLAGS+= -UNO_SSL_SUPPORT
+.else
+CFLAGS+= -DNO_SSL_SUPPORT
+.endif
+
+.if defined(NO_CGI)
+CFLAGS+= -DNO_CGIBIN_SUPPORT
+.else
+CFLAGS+= -UNO_CGIBIN_SUPPORT
+.endif
+
MAN8= bozohttpd.8
MANCOMPRESSED= maybe
PLIST_FILES= libexec/bozohttpd