aboutsummaryrefslogtreecommitdiffstats
path: root/www/cadaver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/cadaver/Makefile')
-rw-r--r--www/cadaver/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index cfba7bbd2f5d..70f452928d18 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -6,16 +6,28 @@
#
PORTNAME= cadaver
-PORTVERSION= 0.10.0
+PORTVERSION= 0.17.0
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/cadaver/
MAINTAINER= tarkhil@over.ru
-LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml
+LIB_DEPENDS= neon.12:${PORTSDIR}/www/neon
+
+.ifndef NO_OPENSSL
+USE_OPENSSL= yes
+.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-netrc
+CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE} \
+ --enable-netrc \
+ --with-neon=${LOCALBASE}
ALL_TARGET= cadaver
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/cadaver.1 ${PREFIX}/man/man1
+
+MAN1= cadaver.1
+
.include <bsd.port.mk>