aboutsummaryrefslogtreecommitdiffstats
path: root/www/cherokee/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/cherokee/Makefile')
-rw-r--r--www/cherokee/Makefile29
1 files changed, 10 insertions, 19 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index bf7f113a6d0c..ec662d29cb00 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= cherokee
-PORTVERSION= 0.5.6
-PORTREVISION= 7
+PORTVERSION= 0.6.1
CATEGORIES= www
-MASTER_SITES= http://www.cherokee-project.com/download/${PORTVERSION:R}/${PORTVERSION}/ \
- CENKES LOCAL/beech
+MASTER_SITES= http://www.cherokee-project.com/download/0.6/${DISTVERSION}/
MAINTAINER= beech@FreeBSD.org
COMMENT= Extremely fast and flexible web server
@@ -23,6 +21,8 @@ USE_LDCONFIG= yes
USE_RC_SUBR= cherokee.sh
USE_GCC= 3.4+
USE_BISON= build
+USE_MYSQL= yes
+USE_OPENLDAP= yes
GNU_CONFIGURE= yes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-wwwroot=${PREFIX}/www/cherokee \
--enable-readdir_r \
--disable-static
-DEFCONFS= advanced.conf cherokee.conf icons.conf mime.compression.types mime.types
+DEFCONFS= cherokee.conf mime.compression.types mime.types
CONFSUBDIRS= ssl mods-available mods-enabled sites-available sites-enabled
MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee_logrotate.1
@@ -57,7 +57,8 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|@mkdir_p@|${MKDIR} --|g'
@${REINPLACE_CMD} -e '/cherokee_replace.*%sysconfdir%/d;/^SUBDIRS/s|doc ||;\
- /^install-data-am/s|install-data-local|install-data-local-config|'\
+ /^install-data-am/s|install-data-local|install-data-local-config|;\
+ /^SUBDIRS/s|windows||'\
${WRKSRC}/Makefile.in
@for i in ${BUILD_WRKSRC}/*.sample.pre;do ${SED} -e \
's:%sysconfdir%:${PREFIX}/etc:g; \
@@ -73,24 +74,14 @@ post-install:
@${INSTALL} -d ${CONFSUBDIRS:S|^|${PREFIX}/etc/cherokee/|}
@for i in ${DEFCONFS};do\
${INSTALL_DATA} ${WRKSRC}/$$i.sample ${PREFIX}/etc/cherokee/$$i.default;done
- @for i in ${WRKSRC}/mods-*.sample;do\
- ${INSTALL_DATA} $$i ${PREFIX}/etc/cherokee/mods-available/$${i#*mods-};done
- @for i in ${WRKSRC}/sites-*.sample;do\
- ${INSTALL_DATA} $$i ${PREFIX}/etc/cherokee/sites-available/$${i#*sites-};done
+ @${INSTALL_DATA} ${WRKSRC}/performance.conf.sample ${PREFIX}/etc/cherokee/cherokee.conf.perf_sample
@:>${PREFIX}/etc/cherokee/mods-enabled/.empty
+ @:>${PREFIX}/etc/cherokee/sites-available/.empty
+ @:>${PREFIX}/etc/cherokee/sites-enabled/.empty
@:>${PREFIX}/etc/cherokee/ssl/.empty
@for i in `${FIND} ${PREFIX}/etc/cherokee/ -name \*.default`;do\
if [ ! -f $${i%.default} ];then ${CP} $$i $${i%.default};fi;done
@for i in `${FIND} ${PREFIX}/etc/cherokee/ -name \*.sample`;do\
if [ ! -f $${i%.sample} ];then ${CP} $$i $${i%.sample};fi;done
- @if [ -z "`${LS} ${PREFIX}/etc/cherokee/sites-enabled/`" ];then\
- ${LN} -sf ../sites-available/default ${PREFIX}/etc/cherokee/sites-enabled/;fi
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}/images/
- @${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/
- @${INSTALL_DATA} ${WRKSRC}/doc/*.png ${DOCSDIR}/
- @${INSTALL_DATA} ${WRKSRC}/doc/images/*.png ${DOCSDIR}/images/
- @${INSTALL_DATA} ${WRKSRC}/doc/develop/Intro.txt ${DOCSDIR}/
-.endif
.include <bsd.port.post.mk>