aboutsummaryrefslogtreecommitdiffstats
path: root/www/cl-lml-cmucl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/cl-lml-cmucl/Makefile')
-rw-r--r--www/cl-lml-cmucl/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/cl-lml-cmucl/Makefile b/www/cl-lml-cmucl/Makefile
new file mode 100644
index 000000000000..11b52f8bc7c4
--- /dev/null
+++ b/www/cl-lml-cmucl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection Makefile for: cl-lml-cmucl
+# Date created: 18 May 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= lml
+PORTVERSION= 2.3.4
+CATEGORIES= www textproc
+MASTER_SITES= http://files.b9.com/lml/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -cmucl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= Lisp Markup Language
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/system-registry/lml.asd:${PORTSDIR}/www/cl-lml \
+ ${LOCALBASE}/lib/common-lisp/asdf/cmuclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-cmucl \
+ lisp:${PORTSDIR}/lang/cmucl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/system-registry/lml.asd:${PORTSDIR}/www/cl-lml \
+ ${LOCALBASE}/lib/common-lisp/asdf/cmuclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-cmucl \
+ lisp:${PORTSDIR}/lang/cmucl
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ lisp -nositeinit -noinit \
+ -load ${LOCALBASE}/etc/asdf-init.lisp \
+ -eval "(asdf:oos 'asdf:compile-op :lml)" \
+ -eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/lml/cmuclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/lml/cmuclfasl/
+
+.include <bsd.port.mk>