aboutsummaryrefslogtreecommitdiffstats
path: root/www/cocoon/Makefile.test-options
diff options
context:
space:
mode:
Diffstat (limited to 'www/cocoon/Makefile.test-options')
-rw-r--r--www/cocoon/Makefile.test-options85
1 files changed, 39 insertions, 46 deletions
diff --git a/www/cocoon/Makefile.test-options b/www/cocoon/Makefile.test-options
index 3fd9ebd9bc74..1a669d12c3dd 100644
--- a/www/cocoon/Makefile.test-options
+++ b/www/cocoon/Makefile.test-options
@@ -14,7 +14,6 @@ BLOCKS+= bsf
.if defined(WITH_CHAPERON)
BLOCKS+= chaperon
-BLOCKS+= xsp
.endif
.if defined(WITH_DATABASES)
@@ -56,14 +55,20 @@ BLOCKS+= xsp
.if defined(WITH_LUCENE)
BLOCKS+= lucene
-BLOCKS+= forms
-BLOCKS+= xsp
.endif
.if defined(WITH_NAMING)
BLOCKS+= naming
.endif
+.if defined(WITH_OJB)
+BLOCKS+= ojb
+BLOCKS+= databases
+BLOCKS+= forms
+BLOCKS+= hsqldb
+BLOCKS+= xsp
+.endif
+
.if defined(WITH_PARANOID)
BLOCKS+= paranoid
.endif
@@ -75,7 +80,8 @@ BLOCKS+= poi
.if defined(WITH_PORTAL)
BLOCKS+= portal
BLOCKS+= authentication-fw
-BLOCKS+= html
+BLOCKS+= cron
+BLOCKS+= forms
BLOCKS+= session-fw
BLOCKS+= xsp
.endif
@@ -112,10 +118,29 @@ BLOCKS+= xsp
BLOCKS+= xsp
.endif
+.if defined(WITH_PHP)
+BLOCKS+= php
+.endif
+
+.if defined(WITH_PORTAL_FW)
+BLOCKS+= portal-fw
+BLOCKS+= authentication-fw
+BLOCKS+= session-fw
+BLOCKS+= xsp
+.endif
+
+.if defined(WITH_SWF)
+BLOCKS+= swf
+.endif
+
+.if defined(WITH_WOODY)
+BLOCKS+= woody
+BLOCKS+= xsp
+.endif
+
.if defined(WITH_APPLES)
BLOCKS+= apples
BLOCKS+= forms
-BLOCKS+= xsp
.endif
.if defined(WITH_ASCIIART)
@@ -145,7 +170,8 @@ BLOCKS+= xsp
.if defined(WITH_FACES)
BLOCKS+= faces
BLOCKS+= authentication-fw
-BLOCKS+= html
+BLOCKS+= cron
+BLOCKS+= forms
BLOCKS+= portal
BLOCKS+= session-fw
BLOCKS+= taglib
@@ -154,7 +180,6 @@ BLOCKS+= xsp
.if defined(WITH_FORMS)
BLOCKS+= forms
-BLOCKS+= xsp
.endif
.if defined(WITH_JAVAFLOW)
@@ -186,14 +211,6 @@ BLOCKS+= asciiart
BLOCKS+= midi
.endif
-.if defined(WITH_OJB)
-BLOCKS+= ojb
-BLOCKS+= databases
-BLOCKS+= forms
-BLOCKS+= hsqldb
-BLOCKS+= xsp
-.endif
-
.if defined(WITH_PETSTORE)
BLOCKS+= petstore
BLOCKS+= databases
@@ -211,25 +228,22 @@ BLOCKS+= proxy
BLOCKS+= qdox
.endif
-.if defined(WITH_REPOSITORY)
-BLOCKS+= repository
+.if defined(WITH_QUERYBEAN)
+BLOCKS+= querybean
BLOCKS+= databases
-BLOCKS+= eventcache
+BLOCKS+= forms
BLOCKS+= hsqldb
-BLOCKS+= jms
+BLOCKS+= lucene
+BLOCKS+= ojb
BLOCKS+= xsp
.endif
-.if defined(WITH_SCRATCHPAD)
-BLOCKS+= scratchpad
-BLOCKS+= axis
-BLOCKS+= batik
-BLOCKS+= cron
+.if defined(WITH_REPOSITORY)
+BLOCKS+= repository
BLOCKS+= databases
BLOCKS+= eventcache
BLOCKS+= hsqldb
BLOCKS+= jms
-BLOCKS+= repository
BLOCKS+= xsp
.endif
@@ -264,7 +278,6 @@ BLOCKS+= tour
BLOCKS+= batik
BLOCKS+= fop
BLOCKS+= forms
-BLOCKS+= xsp
.endif
.if defined(WITH_WEBDAV)
@@ -277,23 +290,3 @@ BLOCKS+= repository
BLOCKS+= xsp
.endif
-.if defined(WITH_PHP)
-BLOCKS+= php
-.endif
-
-.if defined(WITH_PORTAL_FW)
-BLOCKS+= portal-fw
-BLOCKS+= authentication-fw
-BLOCKS+= session-fw
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_SWF)
-BLOCKS+= swf
-.endif
-
-.if defined(WITH_WOODY)
-BLOCKS+= woody
-BLOCKS+= xsp
-.endif
-