aboutsummaryrefslogtreecommitdiffstats
path: root/www/codeigniter17/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/codeigniter17/Makefile')
-rw-r--r--www/codeigniter17/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/www/codeigniter17/Makefile b/www/codeigniter17/Makefile
index 3c7da45fa684..c44434092201 100644
--- a/www/codeigniter17/Makefile
+++ b/www/codeigniter17/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= codeigniter
-PORTVERSION= 1.6.2
+PORTVERSION= 1.6.3
CATEGORIES= www
MASTER_SITES= http://codeigniter.com/download_files/
DISTNAME= CodeIgniter_${PORTVERSION}
@@ -172,6 +172,11 @@ post-install:
@for i in ${CI_CONF_FILES}; do \
if [ ! -f ${WWWDIR}/$$i ]; then \
${CP} -p ${WWWDIR}/$$i.sample ${WWWDIR}/$$i; \
+ else \
+ ${ECHO_MSG} "===> Customized ${WWWDIR}/$$i has not been overwritten"; \
+ if [ ! -z "$UPGRADE_TOOL" ]; then \
+ ${ECHO_MSG} "===> WARNING: You may have to manually merge changes to ${WWWDIR}/$$i.sample into ${WWWDIR}/$$i"; \
+ fi; \
fi; \
done
.if defined(WITH_APACHE)
@@ -189,7 +194,9 @@ post-install:
.if !defined(NOPORTDOCS)
@cd ${WRKSRC}/user_guide/ && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
+
@${CAT} ${PKGMESSAGE}
+
.if ${CGI_EXT} == "-cgi"
@${ECHO_MSG} ""
@${ECHO_MSG} "Your CodeIgniter installation was configured to use the PHP CGI binary."