aboutsummaryrefslogtreecommitdiffstats
path: root/www/dillo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/dillo/Makefile')
-rw-r--r--www/dillo/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/www/dillo/Makefile b/www/dillo/Makefile
index d0b359737d72..25e37e6cfb4d 100644
--- a/www/dillo/Makefile
+++ b/www/dillo/Makefile
@@ -9,34 +9,38 @@
#
PORTNAME= dillo
-PORTVERSION= 0.8.5
-PORTREVISION= 1
+PORTVERSION= 0.8.6
CATEGORIES= www ipv6
MASTER_SITES= http://www.dillo.org/download/
-MAINTAINER?= tmseck@netcologne.de
-COMMENT?= A fast, small graphical Web browser built upon GTK+
+MAINTAINER= tmseck@netcologne.de
+COMMENT= A fast, small graphical Web browser built upon GTK+
-RUN_DEPENDS+= wget:${PORTSDIR}/ftp/wget
-LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_GNOME= gnometarget gtk12
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+= --enable-ipv6 --libdir=${PREFIX}/libexec
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --enable-cookies --enable-ipv6 --enable-threaded-dns \
+ --disable-dlgui \
+ --libdir=${PREFIX}/libexec
.if defined(WITH_DILLO_SSL)
CONFIGURE_ARGS+= --enable-ssl
+EXTRA_PATCHES+= ${PATCHDIR}/enable-ssl.patch
USE_OPENSSL= yes
.else
CONFIGURE_ARGS+= --disable-ssl
.endif
-CONFLICTS?= dillo-i18n-*[0-9]*
+CONFLICTS= dillo-i18n-*[0-9]*
post-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
@@ -44,16 +48,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|dillorc|dillorc.sample|g' ${WRKSRC}/Makefile.in
@${CP} ${WRKSRC}/dillorc ${WRKSRC}/dillorc.sample
-# let a slave port redefine this target if it needs to:
-.if !target(pre-configure)
pre-configure:
.if !defined(WITH_DILLO_SSL)
@${ECHO_CMD} ""
- @${ECHO_CMD} " You can enable dillo's experimental SSL support by specifing"
- @${ECHO_CMD} " WITH_DILLO_SSL=yes in your make environment or on the"
- @${ECHO_CMD} " commandline."
- @${ECHO_CMD} ""
-.endif
+ @${ECHO_CMD} " Set WITH_DILLO_SSL=yes in your make environment or on the"
+ @${ECHO_CMD} " commandline to enable experimental SSL support."
.endif
+ @${ECHO_CMD} ""
.include <bsd.port.mk>