aboutsummaryrefslogtreecommitdiffstats
path: root/www/drupal4-textile
diff options
context:
space:
mode:
Diffstat (limited to 'www/drupal4-textile')
-rw-r--r--www/drupal4-textile/135
-rw-r--r--www/drupal4-textile/Makefile47
-rw-r--r--www/drupal4-textile/distinfo3
-rw-r--r--www/drupal4-textile/files/pkg-install.in27
-rw-r--r--www/drupal4-textile/pkg-descr6
5 files changed, 118 insertions, 0 deletions
diff --git a/www/drupal4-textile/1 b/www/drupal4-textile/1
new file mode 100644
index 000000000000..749233d4c2b8
--- /dev/null
+++ b/www/drupal4-textile/1
@@ -0,0 +1,35 @@
+# A Perforce Change Specification.
+#
+# Change: The change number. 'new' on a new changelist. Read-only.
+# Date: The date this specification was last modified. Read-only.
+# Client: The client on which the changelist was created. Read-only.
+# User: The user who created the changelist. Read-only.
+# Status: Either 'pending' or 'submitted'. Read-only.
+# Description: Comments about the changelist. Required.
+# Jobs: What opened jobs are to be closed by this changelist.
+# You may delete jobs from this list. (New changelists only.)
+# Files: What opened files from the default changelist are to be added
+# to this changelist. You may delete files from this list.
+# (New changelists only.)
+
+Change: new
+
+Client: brooks_pagefault
+
+User: brooks
+
+Status: new
+
+Description:
+ Correct pkg-descr and port creation date. Remove bogus
+ contents of $FreeBSD$
+ PR:
+ Submitted by:
+ Reviewed by:
+ Approved by:
+ Obtained from:
+ MFP4 after:
+
+Files:
+ //depot/user/brooks/ports/drupal-textile/Makefile # edit
+ //depot/user/brooks/ports/drupal-textile/pkg-descr # edit
diff --git a/www/drupal4-textile/Makefile b/www/drupal4-textile/Makefile
new file mode 100644
index 000000000000..d3e6fdbec82a
--- /dev/null
+++ b/www/drupal4-textile/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: drupal-textile
+# Date created: 21 February 2006
+# Whom: Brooks Davis <brooks@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= textile
+DISTVERSION= ${DRUPAL_VERSION}
+PORTREVISION= 20060210
+CATEGORIES= www textproc
+MASTER_SITE_SUBDIR= brooks
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= Textile markup module for Drupal
+
+DRUPAL_MODULE= yes
+MODULE_DIRS= textilephp
+MODULE_FILES= textile.module textilephp/Textile.php
+DOC_DIRS= textilephp/doc textilephp
+DOC_FILES= CHANGELOG.txt CREDITS.txt INSTALL.txt LICENSE.txt README.txt \
+ textilephp/doc/classMTLikeTextile-members.html \
+ textilephp/doc/Textile_8php-source.html \
+ textilephp/doc/Textile_8php.html \
+ textilephp/doc/annotated.html \
+ textilephp/doc/classTextile-members.html \
+ textilephp/doc/classMTLikeTextile.html \
+ textilephp/doc/classMTLikeTextile.png \
+ textilephp/doc/classTextile.html \
+ textilephp/doc/classTextile.png \
+ textilephp/doc/doxygen.css \
+ textilephp/doc/doxygen.png \
+ textilephp/doc/files.html \
+ textilephp/doc/functions.html \
+ textilephp/doc/functions_func.html \
+ textilephp/doc/functions_vars.html \
+ textilephp/doc/hierarchy.html \
+ textilephp/doc/index.html \
+ textilephp/textilephp.doxyfile \
+ textilephp/CHANGELOG \
+ textilephp/CREDITS \
+ textilephp/README \
+ textilephp/TODO
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/drupal/bsd.drupal.mk"
+.include <bsd.port.post.mk>
diff --git a/www/drupal4-textile/distinfo b/www/drupal4-textile/distinfo
new file mode 100644
index 000000000000..b7aefdea085a
--- /dev/null
+++ b/www/drupal4-textile/distinfo
@@ -0,0 +1,3 @@
+MD5 (drupal/textile-4.6.0.tar.gz) = 27af78cb90a4db792a4a9299e51db581
+SHA256 (drupal/textile-4.6.0.tar.gz) = 49e44fd86ce9316eaaaf3e3ae40daa791db09222dc62723bf1d6c5a11aa4a5f9
+SIZE (drupal/textile-4.6.0.tar.gz) = 123431
diff --git a/www/drupal4-textile/files/pkg-install.in b/www/drupal4-textile/files/pkg-install.in
new file mode 100644
index 000000000000..e18d858c77e8
--- /dev/null
+++ b/www/drupal4-textile/files/pkg-install.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+PREFIX=%%PREFIX%%
+CONF_FILES="%%CONF_FILES%%"
+CONF_DIRS="%%CONF_DIRS%%"
+
+case $2 in
+POST-INSTALL)
+ for cfgfile in "${CONF_FILES}"; do
+ if [ ! -e ${PREFIX}/${cfgfile} ]; then
+ cp ${PREFIX}/${cfgfile}-dist ${PREFIX}/${cfgfile}
+ fi
+ done
+ ;;
+DEINSTALL)
+ for cfgfile in "${CONF_FILES}"; do
+ if cmp -s ${PREFIX}/${cfgfile} ${PREFIX}/${cfgfile}-dist ]; then
+ rm ${PREFIX}/${cfgfile}
+ fi
+ done
+ ;;
+POST-DEINSTALL)
+ for cfgdir in "${CONF_DIRS}"; do
+ rmdir ${PREFIX}/${cfgdir} 2> /dev/null || true
+ done
+ ;;
+esac
diff --git a/www/drupal4-textile/pkg-descr b/www/drupal4-textile/pkg-descr
new file mode 100644
index 000000000000..e6f9f528a5ad
--- /dev/null
+++ b/www/drupal4-textile/pkg-descr
@@ -0,0 +1,6 @@
+The Textile module allows you to enter content using Textile, a
+simple, plain text syntax that is filtered into valid (X)HTML. It was
+originally developed by Dean Allen of textism.com, and several different
+versions (in several different programming languages) have been created.
+
+WWW: http://drupal.org/project/textile