aboutsummaryrefslogtreecommitdiffstats
path: root/www/ffproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/ffproxy/Makefile')
-rw-r--r--www/ffproxy/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/www/ffproxy/Makefile b/www/ffproxy/Makefile
index c69faf8565a8..0b3cbf203ef8 100644
--- a/www/ffproxy/Makefile
+++ b/www/ffproxy/Makefile
@@ -6,15 +6,27 @@
#
PORTNAME= ffproxy
-PORTVERSION= 1.4
+PORTVERSION= 1.4.1
CATEGORIES= www
MASTER_SITES= http://faith.eu.org/${PORTNAME}/
-MAINTAINER= krion@FreeBSD.org
+MAINTAINER= krion@FreeBSD.org
COMMENT= Filtering HTTP proxy server
+USE_REINPLACE= yes
+
MAN8= ${PORTNAME}.8
+post-patch:
+ ${REINPLACE_CMD} -e \
+ 's|/etc|${PREFIX}/etc|g ; \
+ s|/usr/local|${PREFIX}|g ; \
+ s|/var/ffproxy|${DOCSDIR}|g' \
+ ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e \
+ 's|/etc|${PREFIX}/etc|g' \
+ ${WRKSRC}/${PORTNAME}.8
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 \