aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox-esr/Makefile')
-rw-r--r--www/firefox-esr/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index a05f72056f59..fe0f3114bcdb 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -177,7 +177,9 @@ do-install:
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
.for i in ${EXTRA_SCRIPTS}
${INSTALL_SCRIPT} ${FILESDIR}/${i} ${PREFIX}/bin
.endfor