aboutsummaryrefslogtreecommitdiffstats
path: root/www/frontpage-ar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/frontpage-ar/Makefile')
-rw-r--r--www/frontpage-ar/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/www/frontpage-ar/Makefile b/www/frontpage-ar/Makefile
new file mode 100644
index 000000000000..83b381276930
--- /dev/null
+++ b/www/frontpage-ar/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: FrontPage Arabic Web Administration
+# Date created: Sat Oct 25 16:30:00 CDT 2001
+# Whom: hetzels@westbend.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= frontpage
+PORTVERSION= 5.0.2.2623
+CATEGORIES?= www
+MASTER_SITES= ftp://ftp.microsoft.com/products/frontpage/FPSE02LangFiles/ \
+ ftp://www.westbend.net/Mirrors/ftp.microsoft.com/Products/frontpage/FPSE02LangFiles/
+PKGNAMESUFFIX?= ar-
+DISTFILES=
+EXTRACT_ONLY=
+
+.for _FP_LANG in ${FP_LANG}
+DISTFILES+= fp${PORTVERSION:S/.//:C/\..*//}_${_FP_LANG}.tar.Z
+.endfor
+
+MAINTAINER= hetzels@westbend.net
+
+RUN_DEPENDS= ${FPSETPERM}:${PORTSDIR}/www/frontpage5
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386 alpha
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+FP_LANG?= ara
+FP_LANGUAGE?= Arabic
+FP_LCID?= 1025
+
+FP_VER= 5.0
+
+FP_DIR= ${PREFIX}/frontpage/version${FP_VER}
+FPSETPERM= ${FP_DIR}/set_default_perms.sh
+
+PLIST_SUB= FP_VER=${FP_VER}
+.ifndef NO_FP_LCID_SUB
+PLIST_SUB+= FP_LCID=${FP_LCID}
+.endif
+
+do-install:
+ @${ECHO_MSG} "===> Untaring FrontPage ${FP_LANGUAGE} Language Extentions to ${PREFIX}"
+.for DISTFILE in ${DISTFILES}
+ @(cd ${PREFIX} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DISTFILE} ${EXTRACT_AFTER_ARGS})
+.endfor
+.for _FP_LCID in ${FP_LCID}
+ @${PERL} -pi -e 's:IMAGESDIR:../images/:g' ${FP_DIR}/admin/${_FP_LCID}/webadmin.css
+ @if [ ! -f ${FP_DIR}/help/${_FP_LCID}/wsgindex.htm ]; then \
+ ${CP} ${FP_DIR}/help/${_FP_LCID}/wsgIndex.htm ${FP_DIR}/help/${_FP_LCID}/wsgindex.htm ; \
+ fi
+ @if [ ! -f ${FP_DIR}/help/${_FP_LCID}/wsgIndex.htm ]; then \
+ ${CP} ${FP_DIR}/help/${_FP_LCID}/wsgindex.htm ${FP_DIR}/help/${_FP_LCID}/wsgIndex.htm ; \
+ fi
+.endfor
+ @${FPSETPERM}
+
+.include <bsd.port.post.mk>