aboutsummaryrefslogtreecommitdiffstats
path: root/www/frontpage
diff options
context:
space:
mode:
Diffstat (limited to 'www/frontpage')
-rw-r--r--www/frontpage/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/frontpage/Makefile b/www/frontpage/Makefile
index 1711c7602e4f..f72a2d5c2b28 100644
--- a/www/frontpage/Makefile
+++ b/www/frontpage/Makefile
@@ -117,6 +117,9 @@ do-install:
@${ECHO_MSG} "===> Untaring FrontPage Extensions to ${PREFIX}"
@(cd ${PREFIX} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${FRONTPAGE} ${EXTRACT_AFTER_ARGS})
@${REINPLACE_CMD} -e 's:IMAGESDIR:../images/:g' ${PREFIX}/${FPCSS}
+ @if [ -f ${PREFIX}/${FPCSS} ]; then \
+ ${RM} ${PREFIX}/${FPCSS}.bak ; \
+ fi
@${RM} ${PREFIX}/${FPHTTPD}/httpd
@${MKDIR} ${MOD_FPDOCDIR}
@${CP} ${PREFIX}/${README} ${MOD_FPDOCDIR}/index.html
@@ -125,5 +128,6 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
+ @${PREFIX}/${FPSETPERM}
.include <bsd.port.post.mk>