aboutsummaryrefslogtreecommitdiffstats
path: root/www/gaeo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/gaeo/Makefile')
-rw-r--r--www/gaeo/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/www/gaeo/Makefile b/www/gaeo/Makefile
index 9efe125e0c42..c19123cb948d 100644
--- a/www/gaeo/Makefile
+++ b/www/gaeo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gaeo
PORTVERSION= 0.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www devel python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -16,18 +17,14 @@ RUN_DEPENDS= google-appengine>=1.1.0:${PORTSDIR}/www/google-appengine \
PROJECTHOST= google-app-engine-oil
USES= zip
-USE_PYTHON= yes
-USE_PYDISTUTILS= easy_install
-
-GAEOHOME= ${PYTHON_SITELIBDIR}/${PYEASYINSTALL_EGG}
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
PORTDOCS= LICENSE NOTICE README.TXT CHANGELOG
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>