aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/galeon/Makefile')
-rw-r--r--www/galeon/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 7763801a343e..b65b50dde7de 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -40,7 +40,11 @@ CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
-D_REENTRANT -D_THREAD_SAFE -fno-rtti" \
- LIBS="-L${LOCALBASE}/lib -L${WRKSRC} -pthread -lgcc_r"
+ LIBS="-L${LOCALBASE}/lib -L${WRKSRC} -pthread ${GCC_R_LIB}"
+
+.if exists(/usr/lib/libgcc_r.a)
+GCC_R_LIB= -lgcc_r
+.endif
post-extract:
.if !defined(WITH_FULL_MOZILLA)