aboutsummaryrefslogtreecommitdiffstats
path: root/www/gist/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/gist/Makefile')
-rw-r--r--www/gist/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/gist/Makefile b/www/gist/Makefile
new file mode 100644
index 000000000000..8c1bf41784bb
--- /dev/null
+++ b/www/gist/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gist
+# Date created: 2009-08-16
+# Whom: Ricky E. <codeblock@eighthbit.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gist
+PORTVERSION= 1.0
+CATEGORIES= www net
+MASTER_SITES= http://github.com/defunkt/gist/raw/master/
+DISTNAME= gist
+EXTRACT_SUFX= .rb
+EXTRACT_ONLY=
+
+MAINTAINER= codeblock@eighthbit.net
+COMMENT= A gist pastebin posting command
+
+USE_RUBY= YES
+NO_BUILD= YES
+PLIST_FILES= bin/gist
+
+do-install:
+ ${INSTALL_SCRIPT} ${DISTDIR}/gist.rb ${PREFIX}/bin/gist
+
+.include <bsd.port.mk>