aboutsummaryrefslogtreecommitdiffstats
path: root/www/gitea/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/gitea/Makefile')
-rw-r--r--www/gitea/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/www/gitea/Makefile b/www/gitea/Makefile
index 6e9746fda4cd..e1a8b734579d 100644
--- a/www/gitea/Makefile
+++ b/www/gitea/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gitea
-PORTVERSION= 1.1.4
+PORTVERSION= 1.2.0
DISTVERSIONPREFIX= v
CATEGORIES= www
@@ -40,6 +40,15 @@ CERT_VARS= GO_TAGS+=cert
PAM_VARS= GO_TAGS+=pam
SQLITE_VARS= GO_TAGS+=sqlite
+post-patch:
+ # Gitea releases don't supply the release version number; the
+ # automatic method to obtain the version number in the Gitea build
+ # system only works when sources are checked out from git.
+ # See https://github.com/go-gitea/gitea/issues/1136#issuecomment-311622745
+ ${SED} -Ei .orig \
+ -e 's#^(var Version = )"[^"]+"#\1"${PORTVERSION}"#' \
+ ${GO_WRKSRC}/main.go
+
do-install:
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
${MKDIR} ${STAGEDIR}${ETCDIR}/conf