aboutsummaryrefslogtreecommitdiffstats
path: root/www/gtkhtml38/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/gtkhtml38/Makefile')
-rw-r--r--www/gtkhtml38/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/gtkhtml38/Makefile b/www/gtkhtml38/Makefile
index d6c51670b6a3..0cebe5dacec6 100644
--- a/www/gtkhtml38/Makefile
+++ b/www/gtkhtml38/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gtkhtml
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/gtkhtml
@@ -32,10 +32,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>