aboutsummaryrefslogtreecommitdiffstats
path: root/www/horde2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/horde2/Makefile')
-rw-r--r--www/horde2/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/www/horde2/Makefile b/www/horde2/Makefile
index d7af11dabd8d..542081912ae9 100644
--- a/www/horde2/Makefile
+++ b/www/horde2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= horde
-PORTVERSION= 2.2
+PORTVERSION= 2.2.1
CATEGORIES= www
MASTER_SITES= ftp://ftp.horde.org/pub/horde/ \
ftp://ftp.au.horde.org/pub/horde/ \
@@ -30,9 +30,9 @@ LIB_DEPENDS+= mcal.0:${PORTSDIR}/misc/libmcal
.endif
# Remark: pear-XML_sql2xml is included, but never used.
RUN_DEPENDS= ${PHP_LIB}/Crypt/CBC.php:${PORTSDIR}/security/pear-Crypt_CBC \
- ${PHP_LIB}/Date.php:${PORTSDIR}/devel/pear-Date \
- ${PHP_LIB}/HTML/Select.php:${PORTSDIR}/devel/pear-HTML_Select \
- ${PHP_LIB}/Log.php:${PORTSDIR}/sysutils/pear-Log \
+ ${PHP_LIB}/Date.php:${PORTSDIR}/devel/pear-Date \
+ ${PHP_LIB}/HTML/Select.php:${PORTSDIR}/devel/pear-HTML_Select_Common \
+ ${PHP_LIB}/Log.php:${PORTSDIR}/sysutils/pear-Log \
${PHP_LIB}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
NO_BUILD= yes
@@ -42,7 +42,8 @@ LDD= /usr/bin/ldd
REINPLACE_ARGS= -i.beforeHorde
DOCS= COPYING README docs/CHANGES docs/CODING_STANDARDS \
- docs/CONTRIBUTING docs/CREDITS docs/HACKING docs/INSTALL
+ docs/CONTRIBUTING docs/CREDITS docs/HACKING docs/INSTALL \
+ docs/TRANSLATIONS
CONFFILE= html.php lang.php mime_drivers.php mime_mapping.php \
motd.php prefs.php registry.php
SUB_DIRS= config graphics lib locale po scripts templates util
@@ -79,6 +80,12 @@ pre-install:
${ECHO_MSG} "" ; \
${FALSE} ; \
fi
+ @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libxml2.so"; then \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "Please configure PHP with DOM XML support." ; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi
@if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libintl.so"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with gettext support." ; \