aboutsummaryrefslogtreecommitdiffstats
path: root/www/hs-http-reverse-proxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hs-http-reverse-proxy/Makefile')
-rw-r--r--www/hs-http-reverse-proxy/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/www/hs-http-reverse-proxy/Makefile b/www/hs-http-reverse-proxy/Makefile
new file mode 100644
index 000000000000..8c0f4ddf8b76
--- /dev/null
+++ b/www/hs-http-reverse-proxy/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= http-reverse-proxy
+PORTVERSION= 0.1.0.6
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Reverse proxy HTTP requests, either over raw sockets or with WAI
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= blaze-builder>=0.3 case-insensitive>=0.4 \
+ classy-prelude-conduit>=0.3 conduit>=0.5 http-conduit>=1.6 \
+ http-types>=0.6 lifted-base>=0.1 monad-control>=0.3 \
+ network network-conduit>=0.6 text>=0.11 wai>=1.3 \
+ warp>=1.3.4 word8>=0.0
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>