aboutsummaryrefslogtreecommitdiffstats
path: root/www/hs-snap
diff options
context:
space:
mode:
Diffstat (limited to 'www/hs-snap')
-rw-r--r--www/hs-snap/Makefile18
-rw-r--r--www/hs-snap/distinfo5
-rw-r--r--www/hs-snap/files/patch-snap.cabal35
3 files changed, 36 insertions, 22 deletions
diff --git a/www/hs-snap/Makefile b/www/hs-snap/Makefile
index 4da6be8e8465..74272b57d28b 100644
--- a/www/hs-snap/Makefile
+++ b/www/hs-snap/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= snap
-PORTVERSION= 0.14.0.6
+PORTVERSION= 1.0.0.1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -9,17 +9,11 @@ COMMENT= Top-level package for the Snap Web Framework
LICENSE= BSD3CLAUSE
-USE_CABAL= aeson>=0.6 attoparsec>=0.10 cereal>=0.3 clientsession>=0.8 \
- comonad>=1.1 configurator>=0.1 directory-tree>=0.11 \
- directory-tree>=0.10 dlist>=0.5 either>=4.3 hashable>=1.1 \
- heist>=0.14 lens>=3.7.6 logict>=0.4.2 \
- MonadCatchIO-transformers>=0.2 mtl>2.0 mwc-random>=0.8 \
- old-time>=1.0 pwstore-fast>=2.2 regex-posix>=0.95 \
- snap-core>=0.9 snap-server>=0.9 stm>=2.2 syb>=0.1 text>=0.11 \
- unordered-containers>=0.1.4 vector>=0.7.1 \
- vector-algorithms>=0.4 xmlhtml>=0.1
-
-EXECUTABLE= snap
+USE_CABAL= aeson attoparsec cereal clientsession configurator \
+ directory-tree dlist hashable heist lens lifted-base \
+ map-syntax monad-control mtl mwc-random pwstore-fast \
+ snap-core snap-server stm text transformers-base \
+ unordered-containers xmlhtml
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-snap/distinfo b/www/hs-snap/distinfo
index c861133d2dbe..4a2104e9fdc8 100644
--- a/www/hs-snap/distinfo
+++ b/www/hs-snap/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cabal/snap-0.14.0.6.tar.gz) = fa9ffc7bf5c6729f7e204daecd50765a220a0ffc2feaf3f6b29977370d8db617
-SIZE (cabal/snap-0.14.0.6.tar.gz) = 84164
+TIMESTAMP = 1499625379
+SHA256 (cabal/snap-1.0.0.1.tar.gz) = 293f16c1404793121d3d85abb6287bbb32f5dc1d82b12146d4bb650052322db8
+SIZE (cabal/snap-1.0.0.1.tar.gz) = 81400
diff --git a/www/hs-snap/files/patch-snap.cabal b/www/hs-snap/files/patch-snap.cabal
index 284efd938544..281c9182d169 100644
--- a/www/hs-snap/files/patch-snap.cabal
+++ b/www/hs-snap/files/patch-snap.cabal
@@ -1,10 +1,29 @@
---- snap.cabal.orig 2015-07-19 02:19:23 UTC
+--- snap.cabal.orig 2016-09-23 03:03:09 UTC
+++ snap.cabal
-@@ -237,6 +237,7 @@ Executable snap
- text >= 0.11 && < 1.3
+@@ -103,7 +103,7 @@ Library
+ Snap.Snaplet.Session.SecureCookie
- extensions:
-+ TemplateHaskell
- OverloadedStrings
-
- ghc-prof-options: -prof -auto-all
+ build-depends:
+- aeson >= 0.6 && < 1.1,
++ aeson >= 0.6 && < 1.3,
+ attoparsec >= 0.10 && < 0.14,
+ base >= 4 && < 5,
+ bytestring >= 0.9.1 && < 0.11,
+@@ -111,7 +111,7 @@ Library
+ clientsession >= 0.8 && < 0.10,
+ configurator >= 0.1 && < 0.4,
+ containers >= 0.2 && < 0.6,
+- directory >= 1.1 && < 1.3,
++ directory >= 1.1 && < 1.4,
+ directory-tree >= 0.10 && < 0.13,
+ dlist >= 0.5 && < 0.9,
+ filepath >= 1.3 && < 1.5,
+@@ -120,7 +120,7 @@ Library
+ -- the version disjunction causes problems with dependency resolution.
+ hashable >= 1.2.0.6 && < 1.3,
+ heist >= 1.0 && < 1.1,
+- lens >= 3.7.6 && < 4.15,
++ lens >= 3.7.6 && < 4.16,
+ lifted-base >= 0.2 && < 0.3,
+ map-syntax >= 0.2 && < 0.3,
+ monad-control >= 0.3 && < 1.1,