aboutsummaryrefslogtreecommitdiffstats
path: root/www/hypermail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hypermail/Makefile')
-rw-r--r--www/hypermail/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/hypermail/Makefile b/www/hypermail/Makefile
new file mode 100644
index 000000000000..d2b5d31e1196
--- /dev/null
+++ b/www/hypermail/Makefile
@@ -0,0 +1,31 @@
+# Created by: mjhsieh
+# $FreeBSD$
+
+PORTNAME= hypermail
+PORTVERSION= 2.2.0
+PORTREVISION= 3
+CATEGORIES= www mail
+MASTER_SITES= SF
+
+MAINTAINER= erwin@FreeBSD.org
+COMMENT= Program to generate a cross-referenced HTML mail archive
+
+LICENSE= GPLv2
+
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm \
+ libpcre.so:${PORTSDIR}/devel/pcre
+
+USES= desthack
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-htmldir=${STAGEDIR}${PREFIX}/share/doc/hypermail \
+ --with-gdbm=${LOCALBASE}
+
+CFLAGS+= -L${LOCALBASE}/lib
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/hypermail \
+ ${STAGEDIR}/${PREFIX}/bin/msg2archive \
+ ${STAGEDIR}/${PREFIX}/bin/rdmsg
+
+.include <bsd.port.mk>