aboutsummaryrefslogtreecommitdiffstats
path: root/www/kompozer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/kompozer/Makefile')
-rw-r--r--www/kompozer/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/www/kompozer/Makefile b/www/kompozer/Makefile
index 1fd3deb4a27a..b61c3f04c747 100644
--- a/www/kompozer/Makefile
+++ b/www/kompozer/Makefile
@@ -7,38 +7,40 @@
#
PORTNAME= kompozer
-DISTVERSION= 0.7.10
-PORTREVISION= 4
+DISTVERSION= 0.8a4
CATEGORIES= www
-MASTER_SITES= SF/${PORTNAME}/current/${PORTVERSION}
-DISTNAME= ${PORTNAME}-${DISTVERSION}dfsg-src
+MASTER_SITES= SF/${PORTNAME}/current/${DISTVERSION}
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= gecko@FreeBSD.org
COMMENT= Complete Web Authoring Suite
WANT_GNOME= yes
WANT_PERL= yes
+USE_BZIP2= yes
+USE_GECKO= gecko
USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}/mozilla
+WRKSRC= ${WRKDIR}/mozilla
MAKEFILE= client.mk
ALL_TARGET= build_all
MOZ_EXTENSIONS= wallet,xml-rpc,xmlextras,pref,universalchardet,spellcheck
+MOZ_OPTIONS= --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
+ --enable-application=composer \
+ --enable-system-cairo
PORT_MOZCONFIG= ${WRKSRC}/composer/config/mozconfig.linux
-BROKEN= KompoZer 0.7.10 is not compatible with GTK 2.14 and higher, hence the crashes.
-
DESKTOP_ENTRIES="Kompozer" "${COMMENT}" \
"${PREFIX}/lib/kompozer/icons/mozicon50.xpm" "${PORTNAME}" \
"Application;Network;" true
-NOT_FOR_ARCHS= ia64 sparc64
+NOT_FOR_ARCHS= ia64
NOT_FOR_ARCHS_REASON_ia64= does not build
-NOT_FOR_ARCHS_REASON_sparc64= crashes in font selection
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/Makefile.common"
post-patch:
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${WRKSRC}/storage/build/Makefile.in
@${RM} -f ${WRKSRC}/config.status ${WRKSRC}/config.cache
@${ECHO_CMD} "LDFLAGS += -L${LOCALBASE}/lib" >> ${WRKSRC}/toolkit/components/Makefile.in
@${ECHO_CMD} "LDFLAGS += -L${LOCALBASE}/lib" >> ${WRKSRC}/toolkit/components/gnome/Makefile.in