aboutsummaryrefslogtreecommitdiffstats
path: root/www/linuxpluginwrapper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/linuxpluginwrapper/Makefile')
-rw-r--r--www/linuxpluginwrapper/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/linuxpluginwrapper/Makefile b/www/linuxpluginwrapper/Makefile
index e0b7384a4f02..e7fb90e5b01c 100644
--- a/www/linuxpluginwrapper/Makefile
+++ b/www/linuxpluginwrapper/Makefile
@@ -56,7 +56,8 @@ RTLD= /libexec/ld-elf.so.1
CFLAGS+= -DDEBUG=1
.endif
-.if (${OSVERSION} < 490102 || ${OSVERSION} >= 500000 && ${OSVERSION} < 501107) && !defined(PACKAGE_BUILDING)
+.if !defined(PACKAGE_BUILDING)
+.if ${OSVERSION} < 490102 || ${OSVERSION} >= 500000 && ${OSVERSION} < 501107
pre-everything::
@if ! strings ${RTLD} | ${GREP} libmap.conf > /dev/null 2>&1; then \
${ECHO_MSG} 'Please enable libmap.conf(5) feature for rtld(1).'; \
@@ -71,6 +72,7 @@ pre-everything::
${FALSE}; \
fi
.endif
+.endif
post-build:
@${SED} -e 's,%%PREFIX%%,${PREFIX},' \