aboutsummaryrefslogtreecommitdiffstats
path: root/www/mediawiki12/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mediawiki12/Makefile')
-rw-r--r--www/mediawiki12/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/mediawiki12/Makefile b/www/mediawiki12/Makefile
new file mode 100644
index 000000000000..6df109ab44eb
--- /dev/null
+++ b/www/mediawiki12/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: www/mediawiki
+# Date created: February 1st 2005
+# Whom: Gerrit Beine <tux@pinguru.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mediawiki
+PORTVERSION= 1.3.10
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= wikipedia
+
+MAINTAINER= tux@pinguru.net
+COMMENT= The wiki enginge used by Wikipedia
+
+NO_BUILD= yes
+USE_PHP= mysql
+WANT_PHP_WEB= yes
+MEDIAWIKIDIR?= www/data-dist/mediawiki
+
+do-install:
+ -${MKDIR} ${PREFIX}/${MEDIAWIKIDIR}
+ @${CP} -r ${WRKSRC}/ ${PREFIX}/${MEDIAWIKIDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MEDIAWIKIDIR}
+
+post-install:
+ @${FIND} ${WRKSRC}/${file} -not -type d \
+ | ${SED} -ne 's,^${WRKSRC},${MEDIAWIKIDIR},p' >> ${TMPPLIST}
+ @${FIND} -d ${WRKSRC}/${file} -type d \
+ | ${SED} -ne 's,^${WRKSRC},@dirrm ${MEDIAWIKIDIR},p' >> ${TMPPLIST}
+ @${SED} -e 's|%%MEDIAWIKIDIR%%|${PREFIX}/${MEDIAWIKIDIR}|' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
amp;id=90dbeeb9a86775fdfdb13460473c0838b63b06e2'>- Update to 3.1jadawin2008-05-085-44/+26 * Reset fenner's port maintainerships. portmgr has taken his commit bitlinimon2008-04-291-1/+1 * - Update to 2.0.15miwi2008-04-272-5/+6 * - Update to 3.7.1miwi2008-04-259-709/+33 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-202-6/+3 * Reset maintainership.jkoshy2008-04-101-1/+1 * Reset maintainership.jkoshy2008-04-101-1/+1 * - Chase the gsl shared lib bump.jadawin2008-04-081-1/+2 * - Add ruby 1.9 supportstas2008-04-061-1/+3 * Geekbench is a cross-platform benchmark suite for Mac OS X, Windows,pav2008-04-064-0/+41 * - Fix buildjadawin2008-04-042-14/+1 * - Re-roll tarballjadawin2008-03-313-7/+19 * - Remove USE_GETOPT_LONG which is a no-op since March 2007pav2008-03-205-7/+0 * Upgrade to 2.4.4.sumikawa2008-03-032-10/+5 * Mark BROKEN: checksum mismatcherwin2008-02-291-0/+2 * 2007-10-31 www/vtiger4: This version is no longer supported by the developersmiwi2008-02-285-224/+0 * - Update to 1.93.04miwi2008-02-253-9/+11 * - Update to 3.0.araujo2008-01-174-6/+28 * - Update to 0.4.0rafan2008-01-136-21/+53 * - Update to 2.0.20071129.araujo2008-01-042-5/+5 * - Update to 0.9.0.jmelo2007-12-264-20/+11 * - Repocopy sysutils/xdd -> benchmarks/xdd since it's a better category for thisgarga2007-12-212-1/+2 * - Move sipp to new category benchmarks. [1]araujo2007-12-171-0/+1 * - Forced commit after repocopy.araujo2007-12-176-98/+6 * Mark as broken: fails to install.linimon2007-11-231-0/+4 * - Mark as unbroken on 7.X.araujo2007-11-042-15/+72 * Take maintainership, I use this quite a lotkris2007-10-281-1/+1 * - Add option for plotting of perf data supportmiwi2007-10-261-2/+10 * - Drop Maintainershipmiwi2007-10-091-1/+1 * - Update to 0.05clsung2007-10-053-7/+11 * Switch autoconf dependencies from 2.53 or 2.59 to 2.61.linimon2007-09-301-1/+2 * - Update maintainer mail adressmiwi2007-09-152-2/+2 * - Update to 2.0.20070906miwi2007-09-154-38/+14 * - Update to 3.0.6miwi2007-09-1412-350/+96 * Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.linimon2007-09-081-4/+0 * - Update to 2.66.jmelo2007-09-052-4/+4 * - Remove the DESTDIR modifications from individual ports as we have a new,gabor2007-08-042-14/+14 * Fix build with gcc 4.2kris2007-07-271-0/+20 * - Set --mandir and --infodir in CONFIGURE_ARGS if the configure scriptrafan2007-07-231-1/+1 * - Patch how makefile uses $(mandir) instead of hacking configure scriptrafan2007-07-162-9/+4 * Fix pkg-plist.maho2007-07-161-4/+2 * - Convert to USE_FORTRANpav2007-07-151-5/+1 * Now we use USE_FORTRAN to use FORTRAN compiler.maho2007-07-151-9/+5 * - Use proper capitalization in my email address.trasz2007-07-122-2/+2 * Postmark was removed from NetApps's site: unbreak by getting a newerthierry2007-07-083-17/+8 * Fix build with gcc 4.2.novel2007-07-081-0/+8 * - Update to 1.2.7miwi2007-07-062-7/+6 * chase math/gsl lib versionijliao2007-06-291-1/+2 * Actually make WITH_SSH conditional.delphij2007-06-151-0/+2 * Add an option to use ssh instead of rsh in distributed measurement.delphij2007-06-151-2/+6 * BROKEN: Checksum mismatchkris2007-06-151-0/+2 * Add tsung 1.2.1, multi-protocol distributed load testing tool.skv2007-06-055-0/+220 * - Update to 2.0miwi2007-05-272-6/+6 * - Fixed distfile unavailable.araujo2007-05-263-9/+8 * Update to 3.283.delphij2007-05-262-4/+4 * - update for gnustep-make-2.0.0dinoex2007-05-251-1/+1 * - Welcome X.org 7.2 \o/.flz2007-05-2011-3/+10 * [patch] cleanup non-supported FreeBSD versionsedwin2007-05-021-7/+1 * The mdtest software is used for testing the metadatamiwi2007-04-305-0/+60 * - Remove workarounds for FreeBSD 4.trasz2007-04-201-4/+0 * Remove 4.x support.itetcu2007-04-191-7/+1 * Fix WWWedwin2007-04-171-1/+1 * Remove unreachable code due to OSVERSION checksedwin2007-04-162-45/+1 * Change my email address to trasz@FreeBSD.org.trasz2007-04-132-2/+2 * Update to 1.1.r8.20070327.stefan2007-04-062-5/+5 * - updated maintainer e-mail addressmm2007-04-051-1/+1 * Add rubygem-railsbench 0.9.2, scripts designed for benchmarking of Railsclsung2007-04-035-0/+85 * Fix email address of maintainer from internet2.edu to shlang.comedwin2007-04-031-1/+1 * - respect CCleeym2007-04-025-69/+99 * - update my email address in ports headerleeym2007-03-311-1/+1 * - Remove NO_CDROM since it´s not restricted anymore.mnag2007-03-251-2/+0 * Reset mharo due to maintainer-timeouts and no response to PRs.linimon2007-03-231-1/+1 * - Fix build crash on amd64miwi2007-03-232-0/+12 * - Fix plist: cover manpage linkspav2007-03-181-8/+3 * - Update to 6.5miwi2007-03-1711-65/+81 * - Take maintainership.miwi2007-03-121-1/+1 * - Fix to install manpage in right place.jmelo2007-03-083-6/+15 * Update to 1.1.r8.20070307ehaupt2007-03-082-5/+5 * - Update to 0.66miwi2007-03-074-8/+47 * - Update to 1.1.r8.20070225miwi2007-03-013-5/+29 * - Update to 0.65rafan2007-02-074-7/+35 * - Allow users to disable largefile supportclsung2007-02-021-2/+9 * - add category gnustepdinoex2007-02-011-1/+1 * - Update to 1.1.r8.20070130rafan2007-01-313-15/+39 * * Make benchmarks/raidtest more accurate and avoid crashesvd2007-01-233-7/+9 * - Update to 1.1.r8.20070116miwi2007-01-182-11/+15 * * Migrate to gfortran.maho2007-01-171-4/+17 * Using gfortran42, and not gcc42.maho2007-01-121-2/+6 * Update to 3.267erwin2007-01-123-34/+13 * Add p5-Benchmark-Forking 0.99, run benchmarks in separate processes.clsung2007-01-085-0/+48 * - Marked broken for 4.Xmiwi2007-01-051-0/+4 * Add a dummy knob WANT_FORTRAN for future use.maho2007-01-041-0/+1 * * Migrate to gfortran42.maho2007-01-043-30/+68 * - update to 0.5.2dinoex2006-12-302-4/+4 * - Update to 1.1.r6.20061208miwi2006-12-229-344/+161 * This is GSBench for GNUstep. It started as a simple conversion of NXBench fordinoex2006-12-156-0/+65 * - If the network card's buffer is full, send returns -1 and setsmnag2006-12-132-0/+17 * Fix build on ia64.shaun2006-12-111-4/+6 * - Fix build problemmiwi2006-12-051-0/+1 * This integer benchmark solves positions in the game of connect-4,miwi2006-11-236-0/+55 * The idea of IMB is to provide a concise set of elementary MPImiwi2006-11-217-0/+111 * Fix pkg-plist.sumikawa2006-11-202-1/+2 * Fix plist.sumikawa2006-11-152-11/+19 * Upgrade to 2.4.2.sumikawa2006-11-0921-233/+69 * Update my email address in all ports that I maintain.laszlof2006-11-071-1/+1 * - Update MASTER_SITESmiwi2006-11-051-1/+1 * Chase the GNOME X11BASE to LOCALBASE move, and fix the build with themarcus2006-10-142-0/+2 * - Update to 0.4.8rafan2006-10-122-6/+4 * Fix rawio for sequential read/write tests:se2006-10-102-13/+32 * Add p5-Benchmark-Stopwatch 0.03, simple timing of stages of your code.clsung2006-09-305-0/+62 * - Update to 1.2.6clsung2006-09-212-5/+5 * BROKEN: Does not compilekris2006-09-171-0/+2 * update to 1.1.r6itetcu2006-09-114-20/+31 * Fix fetching.danfe2006-09-071-1/+1 * Update to 1.26arved2006-09-025-167/+257 * - Mark as broken on 7.x, does not compile.jmelo2006-08-261-1/+7 * - Update to 2.4.1miwi2006-08-222-5/+5 * - Update to 1.3.2miwi2006-08-222-5/+5 * Install to /... instead of to /...se2006-08-122-14/+14 * - Fix build on 4.xmiwi2006-08-091-0/+1 * - update to 2.0clsung2006-08-013-7/+18 * Xdd is a tool for measuring and characterizing disk subsystem I/Ogarga2006-07-2613-0/+484 * - Update to 2.65jmelo2006-07-073-6/+9 * Change all bogus uses of BROKEN to IGNORE. See CHANGES 20060705.linimon2006-07-051-1/+1 * - Fix WWW.jmelo2006-06-12