aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla
diff options
context:
space:
mode:
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile8
-rw-r--r--www/mozilla/distinfo4
-rw-r--r--www/mozilla/files/patch-nsFontMetricsGTK.cpp40
-rw-r--r--www/mozilla/files/patch-nsFontMetricsXlib.cpp40
-rw-r--r--www/mozilla/pkg-plist3
5 files changed, 8 insertions, 87 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 87488fb95bf0..c53879f7fb4b 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= mozilla
-PORTVERSION= 1.0
+PORTVERSION= 1.0.1
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
- http://people.FreeBSD.org/~sobomax/:local
+ http://people.FreeBSD.org/~marcus/:local
MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.rc/rc/}/src \
- sobomax/:local
+ marcus/:local
DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.rc/rc/}${EXTRACT_SUFX} \
libart_lgpl-${PORTVERSION}${EXTRACT_SUFX}:local
@@ -27,7 +27,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
WRKSRC= ${WRKDIR}/${PORTNAME}
-WITHOUT_CHATZILLA= "Contains a buffer overflow reported at http://online.securityfocus.com/archive/1/270249"
+#WITHOUT_CHATZILLA= "Contains a buffer overflow reported at http://online.securityfocus.com/archive/1/270249"
USE_BZIP2= yes
EXTRACT_AFTER_ARGS= | tar -xf - -X ${FILESDIR}/tar-exclude
diff --git a/www/mozilla/distinfo b/www/mozilla/distinfo
index e145e2426723..941728692f41 100644
--- a/www/mozilla/distinfo
+++ b/www/mozilla/distinfo
@@ -1,2 +1,2 @@
-MD5 (mozilla-source-1.0.tar.bz2) = 033da936e48336aa2c5d8bf0aa039056
-MD5 (libart_lgpl-1.0.tar.bz2) = f332c3c026adc1c2c0ceb3ac5847d5f5
+MD5 (mozilla-source-1.0.1.tar.bz2) = 8a4b5be862c3a0c33a86adf3a3a67c09
+MD5 (libart_lgpl-1.0.1.tar.bz2) = f332c3c026adc1c2c0ceb3ac5847d5f5
diff --git a/www/mozilla/files/patch-nsFontMetricsGTK.cpp b/www/mozilla/files/patch-nsFontMetricsGTK.cpp
deleted file mode 100644
index 3bab909b5a89..000000000000
--- a/www/mozilla/files/patch-nsFontMetricsGTK.cpp
+++ /dev/null
@@ -1,40 +0,0 @@
-$FreeBSD$
-
-As reported by Mikko Rapeli and Tom Vogt at
-http://bugzilla.mozilla.org/show_bug.cgi?id=115788 and
-http://bugzilla.mozilla.org/show_bug.cgi?id=150339 the X server can
-abort when Mozilla requests a huge (scalable) font. This is also
-likely to happen to the X font server, or to Xvnc.
-
-This patch is from
-http://bugzilla.mozilla.org/attachment.cgi?id=87432&action=view
-.
-
---- gfx/src/gtk/nsFontMetricsGTK.cpp Mon Jun 10 01:02:08 2002
-+++ gfx/src/gtk/nsFontMetricsGTK.cpp Thu Jun 13 00:06:33 2002
-@@ -87,6 +87,12 @@
- #undef USER_DEFINED
- #define USER_DEFINED "x-user-def"
-
-+// This is the scaling factor that we keep fonts limited to against
-+// the display size. If a pixel size is requested that is more than
-+// this factor larger than the height of the display, it's clamped to
-+// that value instead of the requested size.
-+#define FONT_MAX_FONT_SCALE 2
-+
- #undef NOISY_FONTS
- #undef REALLY_NOISY_FONTS
-
-@@ -1276,7 +1282,12 @@
-
- float app2dev;
- mDeviceContext->GetAppUnitsToDevUnits(app2dev);
-+
- mPixelSize = NSToIntRound(app2dev * mFont->size);
-+ // Make sure to clamp the pixel size to something reasonable so we
-+ // don't make the X server blow up.
-+ mPixelSize = PR_MIN(gdk_screen_height() * FONT_MAX_FONT_SCALE, mPixelSize);
-+
- mStretchIndex = 4; // normal
- mStyleIndex = mFont->style;
-
diff --git a/www/mozilla/files/patch-nsFontMetricsXlib.cpp b/www/mozilla/files/patch-nsFontMetricsXlib.cpp
deleted file mode 100644
index fd470f66d234..000000000000
--- a/www/mozilla/files/patch-nsFontMetricsXlib.cpp
+++ /dev/null
@@ -1,40 +0,0 @@
-$FreeBSD$
-
-As reported by Mikko Rapeli and Tom Vogt at
-http://bugzilla.mozilla.org/show_bug.cgi?id=115788 and
-http://bugzilla.mozilla.org/show_bug.cgi?id=150339 the X server can
-abort when Mozilla requests a huge (scalable) font. This is also
-likely to happen to the X font server, or to Xvnc.
-
-This patch is from
-http://bugzilla.mozilla.org/attachment.cgi?id=87432&action=view
-.
-
---- gfx/src/xlib/nsFontMetricsXlib.cpp Tue Jun 11 16:20:31 2002
-+++ gfx/src/xlib/nsFontMetricsXlib.cpp Thu Jun 13 00:05:47 2002
-@@ -99,6 +99,12 @@
- #undef USER_DEFINED
- #define USER_DEFINED "x-user-def"
-
-+// This is the scaling factor that we keep fonts limited to against
-+// the display size. If a pixel size is requested that is more than
-+// this factor larger than the height of the display, it's clamped to
-+// that value instead of the requested size.
-+#define FONT_MAX_FONT_SCALE 2
-+
- #undef NOISY_FONTS
- #undef REALLY_NOISY_FONTS
-
-@@ -1480,7 +1486,12 @@
-
- float app2dev;
- mDeviceContext->GetAppUnitsToDevUnits(app2dev);
-+
- mPixelSize = NSToIntRound(app2dev * mFont->size);
-+ // Make sure to clamp the pixel size to something reasonable so we
-+ // don't make the X server blow up.
-+ mPixelSize = PR_MIN(XHeightOfScreen(xxlib_rgb_get_screen(gXlibRgbHandle)) * FONT_MAX_FONT_SCALE, mPixelSize);
-+
- mStretchIndex = 4; // Normal
- mStyleIndex = mFont->style;
-
diff --git a/www/mozilla/pkg-plist b/www/mozilla/pkg-plist
index 1eaf93402b43..58b62a0833ff 100644
--- a/www/mozilla/pkg-plist
+++ b/www/mozilla/pkg-plist
@@ -53,7 +53,7 @@ lib/mozilla/components/composer.xpt
lib/mozilla/components/content.xpt
lib/mozilla/components/content_base.xpt
lib/mozilla/components/content_html.xpt
-lib/mozilla/components/content_xsl.xpt
+lib/mozilla/components/content_xslt.xpt
lib/mozilla/components/cookie.xpt
lib/mozilla/components/directory.xpt
lib/mozilla/components/docshell.xpt
@@ -125,6 +125,7 @@ lib/mozilla/components/libimglib2.so
lib/mozilla/components/libimgmng.so
lib/mozilla/components/libimgpng.so
lib/mozilla/components/libimgppm.so
+lib/mozilla/components/libimgxbm.so
%%MOZILLAMAILNEWS%%lib/mozilla/components/libimpComm4xMail.so
%%MOZILLAMAILNEWS%%lib/mozilla/components/libimpText.so
%%MOZILLAMAILNEWS%%lib/mozilla/components/libimport.so