aboutsummaryrefslogtreecommitdiffstats
path: root/www/myfaces/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/myfaces/Makefile')
-rw-r--r--www/myfaces/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/www/myfaces/Makefile b/www/myfaces/Makefile
new file mode 100644
index 000000000000..48f0f5d4a00a
--- /dev/null
+++ b/www/myfaces/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Apache MyFaces
+# Date created: October 04, 2005
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= myfaces
+PORTVERSION= 1.1.0
+CATEGORIES= www devel java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= ${PORTNAME}/binaries
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Free open source JavaServer(tm) Faces implementation
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+.if !defined(NOPORTDOCS)
+PORTDOCS= javadoc tlddoc LICENSE.txt NOTICE.txt
+.endif
+JAR_FILES= myfaces-all.jar myfaces-api.jar myfaces-impl.jar tomahawk.jar
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
+ ${JAR_FILES:S|^|%%DATADIR%%/|}
+PLIST_DIRS= %%DATADIR%%
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/myfaces-all.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${MKDIR} ${DATADIR}
+.for jarfile in ${JAR_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${jarfile} ${DATADIR}/${jarfile}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
+ cd ${WRKSRC} && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+.endif
+
+.include <bsd.port.post.mk>