aboutsummaryrefslogtreecommitdiffstats
path: root/www/netscape3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/netscape3/Makefile')
-rw-r--r--www/netscape3/Makefile52
1 files changed, 0 insertions, 52 deletions
diff --git a/www/netscape3/Makefile b/www/netscape3/Makefile
deleted file mode 100644
index 7c5f688c1b6c..000000000000
--- a/www/netscape3/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-# New ports collection makefile for: netscape
-# Date created: 21 August 1995
-# Whom: asami
-#
-# $FreeBSD$
-#
-
-PORTNAME?= netscape
-PORTVERSION?= 3.04
-CATEGORIES= www
-MASTER_SITES?= ftp://archive:oldies@archive.netscape.com/archive/navigator/3.04/shipping/english/unix/bsdi11/navigator_complete/
-DISTFILES= netscape-v304-export.x86-unknown-bsd.tar.gz
-
-MAINTAINER= sada@FreeBSD.org
-
-RUN_DEPENDS= ${X11BASE}/lib/aout/libX11.so.6.1:${PORTSDIR}/x11/XFree86-aoutlibs
-
-FORBIDDEN= "This version should have 'GIF comment vulnerability'"
-
-ONLY_FOR_ARCHS= i386
-USE_XLIB= yes
-NO_LATEST_LINK= yes
-NO_WRKSUBDIR= yes
-PKGREQ= ${PORTSDIR}/www/netscape4-communicator/pkg-req.aout
-
-.if defined(WITH_128BIT)
-MASTER_SITES+= ftp://ftp.fortify.net/pub/Fortify/ \
- ftp://ftp.za.freebsd.org/pub/Fortify/
-DISTFILES+= ${FORTIFY}.tar.gz
-RESTRICTED= "Contains strong cryptography"
-.endif
-
-FORTIFY= Fortify-1.4.6-unix-x86
-
-.if !defined(WITH_128BIT)
-pre-extract:
- @${ECHO} "You can make Netscape use 128-bit encryption by defining WITH_128BIT"
- @${ECHO} "and defining USA_RESIDENT to NO"
-.endif
-
-pre-install:
- PKG_PREFIX=${PREFIX} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
-
-post-install:
-.if defined(WITH_128BIT)
- cd ${WRKDIR}/${FORTIFY} \
- && (${ECHO_CMD}; ${ECHO_CMD} yes; ${ECHO_CMD} no; ${ECHO_CMD} no) \
- | ./Fortify.sh ${PREFIX}/lib/netscape/netscape.bin
-.endif
- @${CAT} ${DESCR}
-
-.include <bsd.port.mk>