aboutsummaryrefslogtreecommitdiffstats
path: root/www/nextcloud/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/nextcloud/Makefile')
-rw-r--r--www/nextcloud/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/nextcloud/Makefile b/www/nextcloud/Makefile
index e405455b6389..3a17a8865575 100644
--- a/www/nextcloud/Makefile
+++ b/www/nextcloud/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= nextcloud
-PORTVERSION= 10.0.1
-PORTREVISION= 1
+PORTVERSION= 11.0.0
CATEGORIES= www
MASTER_SITES= https://download.nextcloud.com/server/releases/
@@ -10,7 +9,6 @@ MAINTAINER= loic.blot@unix-experience.fr
COMMENT= Personal cloud which runs on your own server
LICENSE= AGPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING-AGPL
USES= cpe php:web tar:bzip2 ssl
USE_PHP= bz2 ctype curl dom fileinfo filter gd hash iconv json \
@@ -50,6 +48,9 @@ SSL_USE= PHP=openssl
WITH_OPENSSL_PORT= yes
.endif
+post-stage:
+ ${RM} ${STAGEDIR}${WWWDIR}/updater/updater.phar
+
do-install:
@${MKDIR} -m 0755 ${STAGEDIR}${WWWDIR}
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}