aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index cccec3228327..d4a194d2132d 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -73,6 +73,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
PASSENGER_MODULE "3rd party passenger module" off \
SLOWFS_CACHE_MODULE "3rd party slowfs_cache module" off \
SUPERVISORD_MODULE "3rd party supervisord module" off \
+ SYSLOG_SUPPORT "3rd party syslog support" off \
UDPLOG_MODULE "3rd party udplog (syslog) module" off
WANT_GNOME= yes
@@ -420,6 +421,12 @@ DISTFILES+= ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}.tar.gz:superviso
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}
.endif
+.if defined(WITH_SYSLOG_SUPPORT)
+NGINX_SYSLOG_SUPPORT_FACILITY?= LOG_DAEMON
+CONFIGURE_ARGS+=--with-syslog --with-syslog-facility=${NGINX_SYSLOG_SUPPORT_FACILITY}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-syslog_support
+.endif
+
.if defined(WITH_UDPLOG_MODULE)
NGINX_UDPLOG_MODULE_VERSION= 1.0.0
MASTER_SITES+= http://www.grid.net.ru/nginx/download/:udplog