aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 631a692d891e..d81bb535aaec 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -91,6 +91,7 @@ OPTIONS_DEFINE= \
REDIS2 \
RTMP \
SET_MISC \
+ SFLOW \
SLOWFS_CACHE \
SRCACHE \
SUPERVISORD \
@@ -174,6 +175,7 @@ RDS_JSON_DESC= 3rd party rds_json module
REDIS2_DESC= 3rd party redis2 module
RTMP_DESC= 3rd party rtmp module
SET_MISC_DESC= 3rd party set_misc module
+SFLOW_DESC= 3rd party sflow module
SLOWFS_CACHE_DESC= 3rd party slowfs_cache module
SRCACHE_DESC= 3rd party srcache module
SUPERVISORD_DESC= 3rd party supervisord module
@@ -678,6 +680,14 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/agentzh-set-misc-nginx-module-${GIT_SET_M
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-agentzh-set-misc-nginx-module::config
.endif
+.if ${PORT_OPTIONS:MSFLOW}
+NGINX_SFLOW_VERSION= 0.9.6
+MASTER_SITES+= http://nginx-sflow-module.googlecode.com/files/:sflow
+DISTFILES+= nginx-sflow-module-${NGINX_SFLOW_VERSION}.tar.gz:sflow
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-sflow-module-${NGINX_SFLOW_VERSION}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_sflow_config.c
+.endif
+
.if ${PORT_OPTIONS:MSLOWFS_CACHE}
NGINX_SLOWFS_CACHE_VERSION= 1.8
MASTER_SITES+= http://labs.frickle.com/files/:slowfs_cache