aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile3
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-syslog_support28
-rw-r--r--www/nginx/files/patch-src::os::unix::ngx_files.c11
4 files changed, 13 insertions, 33 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 3fb253068714..240307d43541 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 1.0.10
-PORTREVISION= 1
+PORTVERSION= 1.0.11
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 724ccac6d822..76bc7412af01 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-1.0.10.tar.gz) = 7221fdb0f2a94875252cb3c406a2cd5895d9bc57874fc1b4f588964fd3361e3c
-SIZE (nginx-1.0.10.tar.gz) = 686011
+SHA256 (nginx-1.0.11.tar.gz) = 4a382de6b89ec7eae03bfc9f9716bca5567993d0ae90fbd5f75c1ea598f7d722
+SIZE (nginx-1.0.11.tar.gz) = 691501
SHA256 (giom-nginx_accept_language_module-02262ce.tar.gz) = 3191f4caa70d9a8942c4f10b6abaaa96af451991d4b5e1e3d7b991376b00bf0c
SIZE (giom-nginx_accept_language_module-02262ce.tar.gz) = 3398
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
diff --git a/www/nginx/files/extra-patch-syslog_support b/www/nginx/files/extra-patch-syslog_support
index d047156687c1..e321cca01fc2 100644
--- a/www/nginx/files/extra-patch-syslog_support
+++ b/www/nginx/files/extra-patch-syslog_support
@@ -210,9 +210,9 @@ index 5f356c3..5232ad6 100644
cat << END > $NGX_MAKEFILE
---- auto/options.orig 2010-06-18 19:51:14.000000000 +0400
-+++ auto/options 2010-12-08 13:00:42.000000000 +0300
-@@ -118,6 +118,8 @@
+--- auto/options.orig 2011-12-15 21:25:00.000000000 +0400
++++ auto/options 2011-12-15 21:28:01.000000000 +0400
+@@ -119,6 +119,8 @@
MD5_OPT=
MD5_ASM=NO
@@ -221,31 +221,23 @@ index 5f356c3..5232ad6 100644
USE_SHA1=NO
SHA1=NONE
SHA1_OPT=
-@@ -270,6 +272,9 @@
+@@ -272,6 +274,9 @@
--with-md5-opt=*) MD5_OPT="$value" ;;
--with-md5-asm) MD5_ASM=YES ;;
-+ --with-syslog) USE_SYSLOG=YES ;;
-+ --with-syslog-facility=*) SYSLOG_FACILITY="$value" ;;
++ --with-syslog) USE_SYSLOG="YES" ;;
++ --with-syslog-facility=*) SYSLOG_FACILITY="$value" ;;
+
--with-sha1=*) SHA1="$value" ;;
--with-sha1-opt=*) SHA1_OPT="$value" ;;
--with-sha1-asm) SHA1_ASM=YES ;;
-@@ -410,6 +415,9 @@
- --with-md5-opt=OPTIONS set additional options for md5 building
+@@ -416,6 +421,9 @@
+ --with-md5-opt=OPTIONS set additional build options for md5
--with-md5-asm use md5 assembler sources
-+ --with-syslog use syslog instead of files to log messages
++ --with-syslog use syslog instead of files to log messages
+ --with-syslog-facility=FACILITY set syslog facility
+
--with-sha1=DIR set path to sha1 library sources
- --with-sha1-opt=OPTIONS set additional options for sha1 building
+ --with-sha1-opt=OPTIONS set additional build options for sha1
--with-sha1-asm use sha1 assembler sources
-@@ -427,6 +435,7 @@
- --with-openssl-opt=OPTIONS set additional options for OpenSSL building
-
- --with-debug enable the debugging logging
-+
-
- END
-
diff --git a/www/nginx/files/patch-src::os::unix::ngx_files.c b/www/nginx/files/patch-src::os::unix::ngx_files.c
deleted file mode 100644
index 018706c60f84..000000000000
--- a/www/nginx/files/patch-src::os::unix::ngx_files.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/os/unix/ngx_files.c.orig 2011-11-21 17:32:42.000000000 +0400
-+++ src/os/unix/ngx_files.c 2011-11-21 17:33:28.000000000 +0400
-@@ -454,7 +454,7 @@
- }
-
-
--#if (NGX_HAVE_POSIX_FADVISE)
-+#if (NGX_HAVE_POSIX_FADVISE) && !(NGX_HAVE_F_READAHEAD)
-
- ngx_int_t
- ngx_read_ahead(ngx_fd_t fd, size_t n)