aboutsummaryrefslogtreecommitdiffstats
path: root/www/owncloud/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/owncloud/Makefile')
-rw-r--r--www/owncloud/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/www/owncloud/Makefile b/www/owncloud/Makefile
new file mode 100644
index 000000000000..079fdc6f42aa
--- /dev/null
+++ b/www/owncloud/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: owncloud
+# Date created: 14 October 2011
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= owncloud
+PORTVERSION= 2
+CATEGORIES= www
+MASTER_SITES= http://owncloud.org/releases/
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= A personal cloud which runs on your own server
+
+BUILD_DEPENDS= mp3info:${PORTSDIR}/audio/mp3info
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_PHP= ctype curl hash json mbstring mysql session simplexml sqlite zip
+
+WWWDOCROOT?= www
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${FIND} -s -d ${WWWDIR} -type f -print | \
+ ${SED} -e "s#${PREFIX}/##g" >> ${TMPPLIST}
+ @${FIND} -s -d ${WWWDIR} -type d -print | \
+ ${SED} -E -e "s#${PREFIX}/#@dirrm #g" >> ${TMPPLIST}
+
+.include <bsd.port.mk>