aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-DBI/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Apache-DBI/Makefile')
-rw-r--r--www/p5-Apache-DBI/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index fdac8f4517c0..52bbd2d2266c 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= Apache-DBI
-PORTVERSION= 1.09
+PORTVERSION= 1.10
CATEGORIES= www databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -25,18 +25,19 @@ MAN3= Apache::DBI.3 Apache::AuthDBI.3
PERL_CONFIGURE= yes
USE_APACHE?= 13+
+
.include <bsd.port.pre.mk>
# prevent from direct including
# ports should use one of the SLAVEPORTS
.if !defined(PKGNAMESUFFIX)
-IGNORE= use ${SLAVEDIRS} instead
+IGNORE= use ${SLAVEDIRS} instead
.endif
.if defined(WITH_MODPERL) && ${APACHE_VERSION} > 13
-IGNORE= mod_perl require apache13 but ${APACHE_PORT} is installed
+IGNORE= mod_perl require apache13 but ${APACHE_PORT} is installed
.elif defined(WITH_MODPERL2) && ${APACHE_VERSION} < 20
-IGNORE= mod_perl2 require at last apache20 but ${APACHE_PORT} is installed
+IGNORE= mod_perl2 require at last apache20 but ${APACHE_PORT} is installed
.endif
.if defined(WITH_MODPERL2)
@@ -48,11 +49,12 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
.endif
PLIST_FILES= %%SITE_PERL%%/Apache/DBI.pm \
- %%SITE_PERL%%/Apache/AuthDBI.pm \
- %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist
+ %%SITE_PERL%%/Apache/AuthDBI.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist
+
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI
-PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI \
- %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache \
- %%SITE_PERL%%/Apache
+PLIST_DIRSTRY= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache \
+ %%SITE_PERL%%/Apache
.include <bsd.port.post.mk>